Manuale dell'utente di Microsoft System Center Configuration Manager 2007 Management Pack per Microsoft System Center Operations Manager 2007
Vedere anche
Logo System Center Configuration Manager 2007

Microsoft System Center Configuration Manager 2007 (ConfigMgr) Management Pack per System Center Operations Manager 2007 consente agli amministratori di gestire e amministrare i server Configuration Manager 2007.

Download del Management Pack più recente e della relativa documentazione

Configuration Manager 2007 Management Pack è disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=103233.

Novità

Per un elenco delle modifiche incluse nel Management Pack, vedere Novità di Configuration Manager 2007 Management Pack.

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack
Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack


Panoramica di Configuration Manager 2007 Management Pack

In questa guida vengono fornite informazioni tecniche e di distribuzione relative a Configuration Manager 2007 Management Pack che consentono di pianificare la distribuzione del Management Pack, conoscere le funzionalità disponibili e utilizzarle in modo ottimale all'interno di un'organizzazione IT.

System Center Configuration Manager 2007 Management Pack per Operations Manager 2007 offre le funzionalità migliorate per il monitoraggio di Configuration Manager 2007 seguenti:

  • Monitoraggio dell'avvio e dell'interruzione di tutti i servizi di Configuration Manager 2007, inclusi i servizi dipendenti critici quali Strumentazione gestione Windows (WMI), il servizio di amministrazione IIS, il servizio Pubblicazione sul Web, il server Servizi di distribuzione Windows, Trivial FTP Daemon, Servizio trasferimento intelligente in background e Microsoft SQL Server™.
  • Invio di avvisi all'amministratore di Configuration Manager 2007 per segnalare messaggi di stato di Configuration Manager 2007 critici.
  • Monitoraggio dei backlog di record dei dati di individuazione, inventario software, inventario hardware, messaggi di stato, messaggi sullo stato attuale e controllo software su server del sito primario e punti di gestione.
  • Monitoraggio dei backlog della posta in uscita nei sistemi del sito.
  • Monitoraggio dell'integrità di un componente e dei ruoli del sistema del sito.
  • Monitoraggio delle attività di valutazione delle raccolte, riepilogo dei messaggi sullo stato attuale e manutenzione del sito, incluso il backup del sito.
  • Monitoraggio degli arresti anomali di SMS Executive.
  • Monitoraggio dell'utilizzo generale della CPU, della memoria e delle risorse di sistema del disco.
  • Monitoraggio delle velocità di elaborazione.
  • Monitoraggio delle tendenze delle prestazioni di numerosi contatori delle prestazioni di Configuration Manager mediante viste e report.
  • Knowledge Base predefinita per tutti gli avvisi e le regole di elaborazione.
  • Individuazione di tutti i computer, le classi e i gruppi di computer di Configuration Manager 2007.
  • Viste di Configuration Manager 2007.
  • Report delle prestazioni, della disponibilità e di configurazione dei gruppi di server Configuration Manager 2007. Questi report collegati si basano sulle funzionalità di report avanzate per le tendenze delle prestazioni, della configurazione e della disponibilità di Systems Center Operations Manager 2007.
  • Attività per eseguire le applicazioni della console di amministrazione di Configuration Manager 2007.
  • Vista dello stato del computer contenente l'integrità di tutti i ruoli del server di Configuration Manager 2007 e del client di Configuration Manager 2007.
  • Viste della gerarchia e dello stato dei siti con informazioni sull'integrità dei siti di una gerarchia e sulla gerarchia stessa.
  • Individuazione dei servizi con informazioni importanti sul server e i client Configuration Manager 2007.
  • Diagramma della topologia della gerarchia dei siti di Configuration Manager 2007.
  • Avvisi configurabili di Configuration Manager 2007 per segnalare errori dei programmi distribuiti tramite le proprietà di programma di Configuration Manager 2007.

Per ulteriori informazioni sulle funzionalità e sugli scenari di monitoraggio, vedere Scenari di monitoraggio del Management Pack per Configuration Manager 2007.

Configuration Manager 2007 Management Pack non è stato progettato per offrire le funzionalità seguenti:

  • Monitoraggio di System Management Server (SMS) 1.2, SMS 2.0 o SMS 2003 né di qualsiasi versione o service pack relativo a tali prodotti.
  • Monitoraggio di ambienti misti con SMS e Configuration Manager, ovvero ambienti in cui vengono eseguite contemporaneamente installazioni di SMS 1.2, SMS 2.0, SMS 2003 e Configuration Manager. Un sito figlio SMS 2003 può dipendere da un sito padre di Configuration Manager 2007.
  • Monitoraggio completo dei computer solo client Configuration Manager 2007 in cui viene eseguito il client di Configuration Manager 2007.
  • Soluzione di monitoraggio pronta all'utilizzo per la gestione di qualsiasi installazione di Configuration Manager 2007 senza la necessità di modifiche. Le soglie delle regole sono diverse per ogni installazione di Configuration Manager 2007 e i clienti devono personalizzare le regole personalmente.

In questa sezione

Novità di Configuration Manager 2007 Management Pack

Conoscenze e competenze consigliate per Configuration Manager 2007 Management Pack

Configurazioni supportate per Configuration Manager 2007 Management Pack

Vedere anche

Concetti

Guida introduttiva a Configuration Manager 2007 Management Pack
Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Novità di Configuration Manager 2007 Management Pack

System Center Configuration Manager 2007 Management Pack per Operations Manager 2007 include opzioni di monitoraggio delle nuove funzionalità, nonché nuovi meccanismi di monitoraggio. Il monitoraggio dei ruoli e delle origini dati obsoleti è stato rimosso.

Supporto aggiuntivo per le funzionalità di Configuration Manager 2007

Configuration Manager 2007 Management Pack consente di monitorare le funzionalità di Configuration Manager 2007 seguenti:

  • Gestione della configurazione desiderata
  • Distribuzione del sistema operativo
  • Protezione accesso alla rete. Il monitoraggio di Protezione accesso alla rete è supportato a partire da Configuration Management 2007 Service Pack 1.
  • Gestione dei dispositivi
  • Riattivazione LAN (WOL)
  • Backup basato su VSS
  • Client mobili, infrastrutture secondarie e per Internet

Aggiunta del monitoraggio della disponibilità del server SQL

Il database di Configuration Manager è ora monitorato dal server del sito anziché a livello locale dal server SQL. Questa operazione viene eseguita dal thread SMS_DATABASE_NOTIFICATION_MONITOR appartenente al servizio SMS Executive. La disponibilità del server SQL può essere monitorata tramite i report di disponibilità.

Aggiunta del monitoraggio della disponibilità del punto di gestione dei dispositivi

Il monitoraggio del punto di gestione dei dispositivi viene eseguito dal componente di gestione del controllo del punto di gestione che genera una transazione sintetica al punto di gestione dei dispositivi per indicare di eseguire una verifica automatica. Il risultato di tale verifica viene interpretato come la disponibilità del ruolo, che può essere monitorata per mezzo di avvisi e report.

Aggiunta del monitoraggio del punto di distribuzione

Il monitoraggio del punto di distribuzione è attualmente disponibile solo per i punti di distribuzione secondari. La disponibilità del ruolo viene segnalata dall'agente del punto di distribuzione secondario in esecuzione in un client di Configuration Manager.

Aggiunta del monitoraggio della disponibilità del punto di aggiornamento del software

La disponibilità del punto di aggiornamento del software indica l'integrità del ruolo e la relativa capacità di sincronizzarsi con gli aggiornamenti disponibili nel server WSUS.

Aggiunta del monitoraggio della disponibilità del punto di migrazione dello stato

Il monitoraggio del punto di migrazione dello stato viene eseguito dal componente di gestione del controllo del punto di migrazione dello stato che genera una transazione sintetica al punto di migrazione dello stato per indicare di eseguire una verifica automatica. Il risultato di tale verifica viene interpretato come la disponibilità del ruolo, che può essere monitorata per mezzo di avvisi e report.

Aggiunta del monitoraggio della disponibilità del punto di servizio PXE

Il monitoraggio del punto di servizio PXE viene eseguito dal componente di gestione del controllo PXE che genera una transazione sintetica al punto di servizio PXE per indicare di accedere al database del sito. Il risultato di tale test viene interpretato come la disponibilità del ruolo, che può essere monitorata per mezzo di avvisi e report.

Aggiunta del monitoraggio della disponibilità del servizio di convalida dell'integrità di sistema

La disponibilità e l'integrità del servizio di convalida dell'integrità di sistema viene segnalata in modo dinamico dal servizio stesso e ne riflette lo stato operativo interno corrente, che può essere monitorato tramite avvisi e report.

Aggiunta del monitoraggio della disponibilità del punto di gestione del bilanciamento del carico di rete

Il componente di gestione del controllo del punto di gestione è stato aggiornato per fornire il monitoraggio sia fisico che virtuale dei punti di gestione del bilanciamento del carico di rete. Il monitoraggio della disponibilità del bilanciamento del carico di rete viene eseguito in modo analogo al monitoraggio di un punto di gestione fisico in Configuration Manager 2007. Viene monitorato anche lo stato di ogni nodo all'interno del bilanciamento del carico di rete.

Aggiunta del monitoraggio della disponibilità dei componenti

Molti componenti sono stati modificati in modo da generare heartbeat contenenti il relativo stato di disponibilità. I problemi relativi alla disponibilità dei componenti vengono segnalati tramite avvisi.

Aggiunta del monitoraggio delle attività di Configuration Manager

Periodicamente vengono eseguite attività per la valutazione delle raccolte, il riepilogo dei messaggi sullo stato attuale e la manutenzione del sito, incluse le operazioni di backup. Le tabelle del database del sito sono state ampliate e i componenti aggiornati per segnalare la durata a lo stato delle attività. Vengono ora segnalate le attività con un'esecuzione più lunga del previsto o che hanno generato errori.

Regole aggiornate per le soglie del numero di file per la cartella della posta in arrivo

Le cartelle della posta in arrivo sono ora monitorate dai contatori delle prestazioni del Management Pack. Nelle versioni precedenti questi contatori sono invece monitorati da uno script.

Aggiunta del monitoraggio della posta in uscita

Il monitoraggio della posta in uscita indica il numero di file di una cartella della posta in uscita e viene segnalato da un contatore delle prestazioni.

Attività di Configuration Manager 2007 avviate dalla console di Operations Manager aggiornate

In SMS 2003, la variabile di ambiente SMS_ADMIN_UI_PATH creata durante l'installazione della console di amministrazione SMS è una variabile di ambiente utente, pertanto solo l'utente che installa la console può avviare le attività SMS da Operations Console. In Configuration Manager 2007 questa variabile è ora una variabile di ambiente di sistema e la limitazione appena descritta non sussiste più. Questa caratteristica influisce sulle attività seguenti:

  • Componente di visualizzazione delle risorse
  • Console di Configuration Manager
  • Componente di gestione dei servizi
  • Messaggio di stato
  • Queste attività sono ora disponibili nel riquadro delle attività ogni volta che è presente un'istanza della classe Server ConfigMgr.

Modalità manutenzione aggiornata per Configuration Manager 2007

La modalità manutenzione di Operations Manager si basa ora sulle funzionalità di Configuration Manager 2007 seguenti:

  • Backup e ripristino
  • Gestione degli aggiornamenti software
  • Distribuzione del software

Il backup e il ripristino chiudono ancora i servizi, ma, poiché l'agente Operations Manager viene precedentemente messo in modalità manutenzione, non è più necessaria alcuna implementazione personalizzata del monitoraggio del servizio nel Management Pack.

Diagramma aggiornato della gerarchia dei siti di Configuration Manager

Il diagramma della gerarchia dei siti di SMS 2003 in Operations Manager (MOM) 2007 è stato aggiornato in modo da eseguire il rollup dello stato. Diagrammi per Configuration Manager 2007 Management Pack

Report aggiornati per Configuration Manager

Configuration Manager include nuovi report basati sui contatori delle prestazioni per ruolo del sistema del sito e per contatore delle elaborazioni degli oggetti, ad esempio quelli relativi ai record dei dati di individuazione. Per ulteriori informazioni sui nuovi report, vedere Report per Configuration Manager 2007 Management Pack.

Ruolo del server Sender di Configuration Manager rimosso

Il server Sender remoto non è più supportato in Configuration Manager 2007. Il supporto per tale ruolo è stato rimosso dal Management Pack.

Ruolo punto di accesso client rimosso

Questi ruoli sono stati rimossi da Configuration Manager 2007. Il monitoraggio di tali ruoli è stato rimosso da Esplora stati.

Monitoraggio delle richieste in uscita di configurazione client rimosso

Il monitoraggio della cartella delle richieste in uscita di configurazione del client di Configuration Manager 2007 (cartella posta in uscita ccr.box) non è più supportato dal Management Pack, in quanto la replica continua dei cluster non passa più attraverso questa cartella.


Conoscenze e competenze consigliate per Configuration Manager 2007 Management Pack

Per distribuire e utilizzare Configuration Manager 2007 Management Pack, è consigliabile disporre delle nozioni e competenze seguenti:

  • Nozioni di utilizzo delle funzionalità di monitoraggio di Operations Manager 2007. Per ulteriori informazioni su Operations Manager 2007, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).
  • Nozioni dell'architettura di progettazione di Operations Manager 2007 e dell'architettura di progettazione distribuita nell'organizzazione.
  • Conoscenza del processo consigliato per la distribuzione dei Management Pack come descritto nella guida alla distribuzione di System Center Operations Manager 2007.
  • Nozioni sui concetti e sulla terminologia di Configuration Manager. Per ulteriori informazioni su Configuration Manager 2007, vedere la pagina Web Raccolta di documentazione tecnica su Configuration Manager (http://go.microsoft.com/fwlink/?LinkID=98803).
  • Nozioni sulla gestibilità e strumentazione di Configuration Manager 2007. Per ulteriori informazioni sulla gestione di Configuration Manager 2007, vedere la pagina Web relativa alla manutenzione di Configuration Manager 2007 (http://go.microsoft.com/fwlink/?LinkId=102324) e Manageability TechCenter (http://go.microsoft.com/fwlink/?LinkId=102326).

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack


Configurazioni supportate per Configuration Manager 2007 Management Pack

I requisiti per System Center Configuration Manager 2007 e Systems Center Operations Manager 2007 sono indicati nelle rispettive guide di distribuzione. Configuration Manager 2007 Management Pack monitora esclusivamente Configuration Manager 2007.

  • È necessario installare l'aggiornamento del Management Pack per garantire la compatibilità di Operations Manager 2007 con MOM 2005 prima di installare Configuration Manager 2007 Management Pack. Per ulteriori informazioni su questo aggiornamento, visitare la pagina Web di download (http://go.microsoft.com/fwlink/?LinkId=101878).
  • Il presente Configuration Manager 2007 Management Pack non monitora System Management Server (SMS) 1.2, SMS 2.0 o SMS 2003.
  • Per monitorare SMS 2003, utilizzare Microsoft SMS 2003 Management Pack per Microsoft System Center Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkId=102297) oppure Systems Management Server (SMS) 2003 Management Pack per MOM 2005 http://go.microsoft.com/fwlink/?LinkId=102297).

Vedere anche

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Distribuzione di Configuration Manager 2007 Management Pack

In questa sezione vengono descritti i passaggi per la distribuzione, il testing e la personalizzazione di Configuration Manager 2007 Management Pack.

In questa sezione

Guida introduttiva a Configuration Manager 2007 Management Pack

Distribuzione dell'agente Microsoft Operations Manager 2007

Testing e progetto pilota per Configuration Manager 2007 Management Pack

Personalizzazione di Configuration Manager 2007 Management Pack

Vedere anche

Concetti

Problemi noti di Configuration Manager 2007 Management Pack
Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack


Guida introduttiva a Configuration Manager 2007 Management Pack

Prima di importare il Management Pack

Prima di distribuire Microsoft® Configuration Manager 2007 Management Pack, vedere la guida alla distribuzione di Microsoft Operations Manager 2007 disponibile nella pagina Web di Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259). In questa sezione vengono fornite istruzioni aggiuntive per la distribuzione dei Management Pack di Operations Manager.

Per distribuire Configuration Manager 2007 Management Pack, è necessario completare le procedure seguenti:

  • Progettare l'ambiente di monitoraggio in base alle specifiche esigenze operative e organizzative e tenere in considerazione i fattori di scala e le prestazioni. È consigliabile eseguire il monitoraggio di tutti i server del sito primario e di tutti i punti di gestione predefiniti.
  • Distribuire l'agente di Operations Manager 2007 in tutti i computer dei componenti server di Configuration Manager 2007 che verranno sottoposti al monitoraggio. È consigliabile prevedere un approccio incrementale.
  • Verificare l'integrità di tutti gli agenti.
  • Configurare gli agenti di Operations Manager 2007 per i provider Configuration Manager 2007 e per i server del sito primario Configuration Manager 2007, in modo tale che possano eseguire l'inoltro dei dati per altri computer.
  • Importare Configuration Manager 2007 Management Pack in un gruppo di configurazione di Operations Manager 2007.
  • Eseguire le attività di testing e le attività per il progetto pilota consigliate.
  • Eseguire le attività di ottimizzazione consigliate.

Come importare Configuration Manager 2007 Management Pack

Prima di poter utilizzare un Management Pack per eseguire il monitoraggio delle installazioni di Configuration Manager 2007, è necessario importare il Management Pack in Operations Manager 2007. Per istruzioni sulle procedure da eseguire a tale scopo, vedere la sezione relativa all'importazione di un Management Pack in Operations Manager 2007 nella pagina Web relativa a Operations Manager (http://go.microsoft.com/fwlink/?LinkID=98348).

Creare un nuovo Management Pack per le personalizzazioni

Nella maggior parte dei casi, il file del Management Pack è bloccato e non è possibile modificarne le impostazioni originali. È tuttavia possibile creare personalizzazioni, ad esempio sostituzioni o nuovi oggetti di monitoraggio, che possono essere salvati in un altro Management Pack. Per impostazione predefinita, Operations Manager salva tutte le personalizzazioni nel Management Pack predefinito. È consigliabile tuttavia creare un Management Pack distinto per ognuno dei Management Pack bloccati che si desidera personalizzare.

La creazione di un nuovo Management Pack nel quale archiviare le sostituzioni offre i vantaggi seguenti:

  • Semplifica l'esportazione delle personalizzazioni create negli ambienti di testing e di preproduzione all'interno dell'ambiente di produzione. Ad esempio, anziché esportare un Management Pack predefinito che include le personalizzazioni di più Management Pack, è possibile esportare unicamente il Management Pack che contiene le personalizzazioni di un singolo Management Pack.
  • Consente di eliminare il Management Pack originale senza che sia necessario eliminare il Management Pack predefinito. Un Management Pack che contiene personalizzazioni dipende dal Management Pack originale. Questa dipendenza rende necessaria l'eliminazione del Management Pack con le personalizzazioni prima di poter eliminare il Management Pack originale. Se tutte le personalizzazioni create vengono salvate nel Management Pack predefinito, prima di poter eliminare il Management Pack originale sarà necessario eliminare il Management Pack predefinito.
  • Semplifica la registrazione e l'aggiornamento delle personalizzazioni in singoli Management Pack.

Per ulteriori informazioni sui Management Pack bloccati e non bloccati, vedere Formati dei Management Pack. Per ulteriori informazioni sulle personalizzazioni dei Management Pack e sul Management Pack predefinito, vedere Informazioni sui Management Pack.

Per creare un nuovo Management Pack per le personalizzazioni

  1. Aprire Operations Console e quindi fare clic sul pulsante Amministrazione.

  2. Fare clic con il pulsante destro del mouse su Management Pack e quindi scegliere Crea nuovo Management Pack.

  3. Immettere un nome, ad esempio ConfigMgr 2007 MP Personalizzazioni, e quindi fare clic su Avanti.

  4. Fare clic su Crea.

Vedere anche

Concetti

Distribuzione dell'agente Microsoft Operations Manager 2007
Testing e progetto pilota per Configuration Manager 2007 Management Pack
Personalizzazione di Configuration Manager 2007 Management Pack


Distribuzione dell'agente Microsoft Operations Manager 2007

L'agente Microsoft Operations Manager viene eseguito su tutti i computer monitorati da Operations Manager. Per visualizzare i gruppi di computer monitorati con Configuration Manager 2007 Management Pack, vedere la sezione Gruppi di computer per Configuration Manager 2007 Management Pack in questa guida. L'agente Microsoft Operations Manager 2007 raccoglie i dati del monitoraggio nel computer gestito, applica regole ai dati raccolti e quindi invia i dati risultanti al Data Consolidator Agent Manager (DCAM). La funzionalità di monitoraggio in un computer agente è disponibile nel servizio Operations Manager 2007 (HealthService.exe), nell'host Operations Manager 2007 (MonitoringHost.exe) e nell’account azione agente.

Per distribuire l'agente Microsoft Operations Manager 2007, è possibile utilizzare l'installazione guidata di Operations Manager 2007 o la distribuzione del software di Configuration Manager. Per ulteriori informazioni sulla distribuzione dell'agente Microsoft Operations Manager 2007 e sull'utilizzo dell'installazione guidata di Operations Manager 2007, vedere l'argomento relativo all'individuazione dei computer e alla distribuzione di agenti Operations Manager nella guida di distribuzione di Microsoft Operations Manager 2007. Per ulteriori informazioni, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Nota
È consigliabile eseguire l'agente Microsoft Operations Manager 2007 nei computer provider Configuration Manager tramite l'account LocalSystem o un account con diritti sufficienti per accedere alla radice degli spazi dei nomi WMI di Configuration Manager, radice\cimv2, radice\sms, alla chiave del Registro di sistema di SMS e alle relative sottochiavi.

Per determinare se è possibile utilizzare il monitoraggio senza agente nell'ambiente in uso, vedere "Supporto per il monitoraggio senza agenti" in Scenari di monitoraggio del Management Pack per Configuration Manager 2007.

Definizione della variabile di ambiente SMS per il supporto delle regole basate su registri

Alcune regole di Configuration Manager Management Pack utilizzano i file di registro di Configuration Manager per individuare eventuali errori.

Le regole seguenti in ConfigMgr Site Servers - Common si basano sui file sender.log, distmgr.log e policypv.log, rispettivamente:

  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione standard)
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite la connessione RAS
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione avanzata)
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile elaborare un pacchetto
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile inserire un pacchetto SMS perché il contenuto di tipo SDM non è presente nella tabella CI_Contents
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di aggiornamento software dal database di sito SMS
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di aggiornamento software
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di conformità dal database di sito SMS
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di conformità
  • Componente ConfigMgr 2007: provider di criteri - impossibile inviare notifica di una modifica dei criteri al componente di gestione della gerarchia

Per monitorare questi registri, è necessario specificare la cartella di installazione di Configuration Manager. A tale scopo, creare la variabile di ambiente di sistema %SMS_INSTALL_DIR_PATH% in un server del sito, in modo che l'agente MOM in esecuzione con l'account LocalSystem o un contesto utente di amministratore locale possa accedere ai file di registro nella directory %SMS_INSTALL_DIR_PATH%\Logs. Per ulteriori informazioni sull'impostazione delle variabili di ambiente di sistema, vedere la pagina Web specifica sull'argomento (http://go.microsoft.com/fwlink/?LinkId=92316).

Per fare in modo che l'agente Operations Manager utilizzi questa variabile di ambiente di sistema, potrebbe essere necessario riavviare il server del sito Configuration Manager.

Configurazione dei computer agente per l'esecuzione in scenari con privilegi di basso livello

La funzionalità di monitoraggio in un computer agente è disponibile nel servizio Operations Manager 2007 (HealthService.exe), nell'host Operations Manager 2007 (MonitoringHost.exe) e nell’account azione agente. In Microsoft Windows® 2000 l'account azione deve essere membro del gruppo degli amministratori locali. In Microsoft Windows™ 2003 è possibile utilizzare un account con privilegi di basso livello come account azione dell'agente in determinate circostanze. La configurazione dell'account azione e del contesto utente in cui vengono eseguiti il servizio Operations Manager 2007 e l'host Operations Manager 2007 con i diritti e le autorizzazioni necessarie per l'esecuzione delle funzionalità di Configuration Manager 2007 Management Pack richiede tuttavia numerose operazioni di configurazione manuali nel computer agente. In Microsoft Windows Server™ 2003 l'account azione dell'agente deve disporre dei diritti utente e delle autorizzazioni minime seguenti:

  • Membro del gruppo degli utenti locali
  • Accesso ai registri eventi di Windows
  • Autorizzazione di gestione dei registri di controllo e di protezione (SeSecurityPrivilege)
  • Autorizzazione di generazione dei controlli di protezione (SeAuditPrivilege)
  • Autorizzazione Consenti accesso locale (SeInteractiveLogonRight)

In uno scenario con privilegi di basso livello, Configuration Manager 2007 Management Pack richiede che l'account utilizzato come account azione dell'agente disponga di diritti e autorizzazioni aggiuntive. Nella tabella seguente sono indicati i diritti di accesso da configurare manualmente.

Tipi di accesso necessari per Configuration Manager 2007 Management Pack

Risorsa | Tipo di accesso | Istruzioni
Registro eventi di Windows | Lettura | È necessario concedere all'account azione il privilegio per la Gestione file registro di controllo e di protezione utilizzando i criteri locali o globali.
Chiavi del Registro di sistema di SMS | Lettura | HKLM\Software\Microsoft\SMS Aggiungere l'account azione alle proprietà del Registro di sistema e concedere l'accesso in lettura ereditato da tutte le sottochiavi.
Chiavi del Registro di sistema dei servizi di Win32 | Lettura | HKLM\System\CurrentControlSet\Services Aggiungere l'account azione al gruppo degli utenti locali.
File temporanei generati da script | Lettura e scrittura | Il percorso specificato dalla variabile TMP per l'account azione. Per LocalSystem è %Windir%\Temp Aggiungere l'account azione al gruppo degli utenti locali.
File di registro di SMS | Lettura | <ConfigMgrInstallFolder> \Logs Aggiungere l'account azione alle proprietà della cartella.
Spazi dei nomi WMI | Lettura | radice e radice\cimv2 Non sono necessarie operazioni.
Spazi dei nomi WMI di SMS | Lettura | Non sono necessarie operazioni.
Classi WMI di SMS | Lettura | SMS_Site SMS_R_System SMS_SiteControlFile SMS_ProviderLocation SMS_SCI_SiteDefinition SMS_SystemResourceList SMS_SystemResourceList SMS_SiteSystemSummarizer Aggiungere l'account azione alla classe per tutte le istanze
Diritti di accesso con protezione per l'istanza predefinita | Concedi accesso | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre dei diritti Concedi accesso per l'accesso con protezione. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Security\Logins.
Accesso al database master nell'istanza predefinita (necessario per identificare il database di sito SMS) | Autorizza | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre del diritto di autorizzazione dell'accesso al database master. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Databases\Master\Users. Mantenere tutte le autorizzazioni predefinite associate a questo nuovo utente.
Accesso al database di sito SMS nell'istanza predefinita | Autorizza | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre del diritto di autorizzazione dell'accesso al database del sito SMS. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Databases\<SMS site>\Users. Mantenere tutte le autorizzazioni predefinite associate a questo nuovo utente.

Vedere anche

Concetti

Personalizzazione di Configuration Manager 2007 Management Pack
Guida introduttiva a Configuration Manager 2007 Management Pack
Problemi noti di Configuration Manager 2007 Management Pack
Testing e progetto pilota per Configuration Manager 2007 Management Pack

Altre risorse

Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Testing e progetto pilota per Configuration Manager 2007 Management Pack

Oltre ai suggerimenti generali per i test dei Management Pack descritti nella guida alla distribuzione di Microsoft Operations Manager 2007, in questa sezione sono elencate le attività per il testing appropriate per Configuration Manager 2007 Management Pack. Per ulteriori informazioni sul testing dei Management Pack, vedere la pagina Web relativa a Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Attività per il testing

  • Verificare che i gruppi di computer Configuration Manager 2007 contengano computer che eseguono Configuration Manager 2007.
  • Dopo aver attivato le regole rilevanti, verificare che le viste e i report in Operations Manager 2007 funzionino correttamente. Sono incluse le viste relative alle velocità di elaborazione di Configuration Manager 2007 e ai backlog di Configuration Manager 2007.
  • Per impostazione predefinita, alcune regole relative ad altri Management Pack, ad esempio i Management Pack di IIS e SQL Server, sono disattivate in Configuration Manager 2007 Management Pack. A seconda degli altri Management Pack distribuiti, è necessario controllare tali regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.
  • Per impostazione predefinita, tutte le regole di controllo delle prestazioni sono disattivare per ridurre al minimo l'impatto sulla CPU, sulla memoria e sulle risorse di rete dell'agente. È possibile attivare queste regole per un monitoraggio più approfondito dell’agente.
  • Alcuni script di Configuration Manager 2007 eseguiti in un computer provider Configuration Manager 2007, in un server del sito Configuration Manager 2007 o che accedono a un database del sito Configuration Manager 2007 non vengono eseguiti in modalità senza agente. Verificare che tutti i computer dei gruppi di computer Provider Microsoft ConfigMgr 2007 e Server di database del sito Microsoft ConfigMgr 2007 siano configurati come gestiti tramite agente. Inoltre, poiché alcuni di questi script potrebbero inoltrare eventi, verificare che tali agenti siano configurati per consentire l'inoltro dei dati.
  • Per supportare i cluster SQL, tutti gli script eseguiti con il database del sito ConfigMgr vengono eseguiti dal server del sito. Verificare che gli script non generino errori o avvisi.

Vedere anche

Concetti

Personalizzazione di Configuration Manager 2007 Management Pack
Distribuzione dell'agente Microsoft Operations Manager 2007
Problemi noti di Configuration Manager 2007 Management Pack

Altre risorse

Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Testing e progetto pilota per Configuration Manager 2007 Management Pack

Oltre ai consigli generali per i test dei Management Pack descritti nella guida alla distribuzione di Microsoft Operations Manager 2007, in questa sezione sono elencate le attività per il progetto pilota appropriate per Configuration Manager 2007 Management Pack. Per ulteriori informazioni sul testing dei Management Pack, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Attività per il progetto pilota

  • Verificare che il processo di distribuzione o aggiornamento dalla versione precedente di Configuration Manager 2007 Management Pack sia stato eseguito correttamente.
  • Verificare e modificare le soglie prestazioni personalizzate per il proprio ambiente tramite Creazione e modifica nella console. Selezionare un ambito o cercare le regole appropriate.
  • Attivare le regole per le prestazioni in varie fasi per valutare l'impatto di tali regole sulle prestazioni di Operations Manager 2007.
  • Controllare che i gruppi di computer di Configuration Manager 2007 includano computer che eseguono Configuration Manager 2007.
  • Dopo aver attivato le regole rilevanti, verificare che le viste e i report in Operations Manager 2007 funzionino correttamente. Sono incluse le viste relative alle velocità di elaborazione, ai totali di elaborazione e ai backlog di Configuration Manager 2007.
  • Per impostazione predefinita, alcune regole relative ad altri Management Pack sono disattivate. A seconda degli altri Management Pack distribuiti, è necessario controllare le regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.
  • Per impostazione predefinita, alcune regole relative alle prestazioni sono disattivare per ridurre al minimo l'impatto sulla CPU, sulla memoria e sulle risorse di rete dell'agente. È possibile attivare queste regole per un monitoraggio più approfondito dell’agente.
  • Verificare che gli eventi e gli avvisi di errore di script di Configuration Manager 2007 non vengano generati. Tali eventi indicano in genere problemi relativi alle autorizzazioni di accesso per lo script.
  • Verificare che le dimensioni dei server Operations Manager e SQL siano sufficienti per il carico di produzione.
  • Verificare i processi operativi e i requisiti del personale.
  • Controllare che le notifiche funzionino correttamente.
  • Verificare che le autorizzazioni utilizzate da Operations Manager 2007 siano sufficienti per una corretta esecuzione, senza essere eccessive.
  • L'agente account azione può essere eseguito solo da un account LocalSystem. Se l'agente non viene eseguito con privilegi LocalSystem, verificare che siano soddisfatti i diritti minimi di protezione. Per ulteriori informazioni, vedere la sezione "Configurazione dei computer agente per l'esecuzione in scenari con privilegi di basso livello" in Distribuzione dell'agente Microsoft Operations Manager 2007 in questa guida.
  • Verificare che i ruoli Server Configuration Manager 2007 e Client Configuration Manager 2007 siano presenti nella vista Stato computer. Fare clic su un computer che ospita ciascuno di questi ruoli e verificare che le proprietà siano visibili nel riquadro dei dettagli.
  • Nella vista Stato computer, fare clic su un'istanza del Server ConfigMgr e del Client ConfigMgr e controllare che i relativi ruoli siano visibili nel riquadro dei dettagli.
  • Nella vista Stato computer fare doppio clic su un'istanza del Server ConfigMgr e del Client ConfigMgr, quindi controllarne le proprietà nel riquadro dei dettagli nella vista dello stato.
  • Verificare che le viste dei siti e della gerarchia dei siti funzionino.
  • Verificare che le attività della console di amministrazione di Configuration Manager 2007 funzionino facendo clic su un'attività. Se l'attività non viene eseguita, verificare che la console di amministrazione di Configuration Manager 2007 sia stata installata e che l'utente connesso disponga di autorizzazioni sufficienti per eseguire le attività della console.
  • Controllare il Diagramma gerarchia siti. Verificare che tutti i sistemi del sito vengano visualizzati per i siti in cui è installato localmente l'agente Microsoft Operations Manager 2007 nel relativo provider Configuration Manager 2007. Se un sistema del sito non viene visualizzato, aprire la console di amministrazione di Configuration Manager 2007 per controllare se il sistema del sito è stato individuato dal sito ed è presente nella raccolta di tutti i sistemi. Controllare inoltre che sia stato specificato il nome di dominio completo (FQDN) per ogni server.

Al termine del progetto pilota e dell'ottimizzazione, esportare il Configuration Manager 2007 Management Pack predefinito o personalizzato creato per eseguire il backup delle modifiche apportate.

Vedere anche

Concetti

Personalizzazione di Configuration Manager 2007 Management Pack
Distribuzione dell'agente Microsoft Operations Manager 2007
Problemi noti di Configuration Manager 2007 Management Pack

Altre risorse

Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Personalizzazione di Configuration Manager 2007 Management Pack

Per ottenere un monitoraggio ottimale, è possibile personalizzare Configuration Manager 2007 Management Pack in base alle esigenze della propria organizzazione. Se le regole esistenti non soddisfano i requisiti aziendali, modificarle o crearne di nuove.

Nota Eseguire sempre il backup di Configuration Manager 2007 Management Pack prima di apportare modifiche. L'esportazione guidata di Operations Manager 2007 Management Pack consente di eseguire il backup del Management Pack predefinito o dei Management Pack per cui non è stato eseguito il sealing.

Le operazioni di personalizzazione possono includere:

  • Attivazione e disattivazione di regole tramite sostituzioni.
  • Creazione di nuove regole e monitoraggi.
  • Modifica dei criteri degli avvisi, della gravità degli avvisi ed eliminazione degli avvisi.
  • Impostazione di soglie personalizzate per i monitoraggi. Tutti i monitoraggi di soglia prestazioni possono essere configurati. Se la soglia predefinita non è ottimale, è possibile che vengano visualizzati avvisi non necessari o che non ne vengano visualizzati nel caso in cui la soglia sia troppo elevata per l'ambiente corrente.
  • Configurazione della soglia di monitoraggio e dell'intervallo di polling della posta in arrivo tramite sostituzioni di regole e monitoraggi.
  • Aggiunta di nuove regole degli eventi di monitoraggio della posta in arrivo personalizzati e basati su script. Per aggiungere una nuova regola di monitoraggio della posta in arrivo, creare una nuova regola nel Management Pack predefinito o personalizzato, quindi creare le sostituzioni per i parametri di input dello script (FileCountThreshold e InboxDirectoryName) e pianificare.
  • Impostazione degli intervalli di polling per il controllo delle prestazioni tramite sostituzioni.
  • Aggiunta di contenuto alla Knowledge Base della società.
  • Personalizzazione delle risposte agli avvisi modificando o aggiungendo nuove risposte a regole o monitoraggi.
  • L'attivazione delle regole di controllo delle prestazioni nell'agente genera una grande quantità di dati e potrebbe ridurre le prestazioni. Le regole di controllo delle prestazioni sono disattivate per impostazione predefinita per consentire all'utente di decidere se un eventuale impatto sulle prestazioni sia accettabile. Controllare le regole relative alle prestazioni e attivarle in piccoli batch, per poter valutare l'impatto di tali regole sulle prestazioni di Operations Manager 2007 e sulle dimensioni del database.
  • Controllo dell'applicabilità delle regole nell'ambiente corrente. Per impostazione predefinita, alcune regole relative ad altri Management Pack sono disattivate. A seconda degli altri Management Pack distribuiti, è necessario controllare le regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.

Per ulteriori informazioni sulle personalizzazioni del Management Pack e su come esportarle, vedere gli argomenti relativi ai Management Pack in Operations Manager 2007 e all'esportazione delle personalizzazioni dei Management Pack nella pagina Web Operations Manager 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=100980.

Monitoraggio della posta in arrivo

L'esportazione guidata di Operations Manager 2007 consente di salvare le modifiche del Management Pack predefinito o di qualsiasi Management Pack personalizzato creato prima di apportare ulteriori modifiche.

Configurazione delle regole di monitoraggio della posta in arrivo

Per distribuire queste regole in server del sito centrali, primari e secondari, è necessario creare nuove regole nel Management Pack basate sulle regole del gruppo Microsoft ConfigMgr 2007 Site Servers - Common. È quindi possibile associare queste regole alla classe di server del sito appropriata, modificare la soglia e attivare la regola.

  • ConfigMgr Inbox: Monitor inbox
  • ConfigMgr Inbox: Monitor inbox script error
  • ConfigMgr Inbox: Threshold exceeded

La regola di elaborazione degli eventi ConfigMgr Inbox: Threshold exceeded consente di monitorare gli eventi tramite lo script ConfigMgr: Monitor Inbox script error. Viene generato un unico avviso per ogni cartella della posta in arrivo che oltrepassa la soglia specificata.

La soglia predefinita per questo script è 10.000 file per ogni cartella. È possibile creare una sostituzione per questo valore nel Management Pack predefinito o personalizzato per questo o altri parametri dello script. Se la soglia viene superata, verrà generato un evento di soglia superata. È possibile modificare le impostazioni di soglia calcolando il carico giornaliero previsto sui server per ogni processo funzionante e quindi aggiungere una percentuale accettabile di buffer. Le regole di monitoraggio della posta in arrivo vengono eseguite una volta al giorno per impostazione predefinita, in incrementi di 15 minuti a partire dalle ore 01.00. Per ridurre al minimo l'impatto sulle prestazioni, è consigliabile mantenere questo intervallo o impostarlo in modo da ridurre la sovrapposizione dell'esecuzione degli script tra le regole di monitoraggio della posta in arrivo.

Nella tabella seguente sono elencate le regole di monitoraggio della posta in arrivo, le soglie predefinite e le cartelle della posta in arrivo monitorate dal provider SMS Executive.

Monitoraggio della posta in arrivo di SMS Executive

Nome regola di monitoraggio della posta in arrivo | Soglia predefinita | Nome cartella
ConfigMgr Inbox: Monitor inbox script error | N/D | N/D
ConfigMgr Inbox: Threshold exceeded | N/D | N/D
ConfigMgr Inbox: Monitor <nome directory posta in arrivo> | 10000 | Inboxes\auth\dataldr.box

Procedura per eseguire la sostituzione delle regole degli eventi di monitoraggio della posta in arrivo

Prima di eseguire la sostituzione di una regola degli eventi di monitoraggio della posta in arrivo, è necessario che il server del sito Operations Manager 2007 individui gli oggetti del server del sito Configuration Manager 2007 di tipo Server del sito Microsoft ConfigMgr 2007.

Per eseguire la sostituzione delle regole degli eventi di monitoraggio della posta in arrivo

  1. Nella console di System Center Operations Manager 2007 fare clic su Creazione e modifica.

  2. Passare a Creazione e modifica > Oggetti Management Pack > Regole.

  3. Se la casella di testo Cerca non è disponibile, passare a Visualizza e quindi fare clic su Trova.

  4. Fare clic su Cambia ambito, quindi impostare l'ambito per i Server del sito Microsoft ConfigMgr 2007.

  5. Fare clic con il pulsante destro del mouse su una regola di eventi di monitoraggio della posta in arrivo di ConfigMgr appropriata da modificare, selezionare Sostituisci regola e quindi fare clic su Tutti gli oggetti di tipo: Server del sito Microsoft ConfigMgr 2007.

  6. In Proprietà di sostituzione selezionare la casella di controllo Attivato relativa alla sostituzione e impostare Impostazioni sostituzioni su Vero per attivare la regola o su Falso per disattivarla.

  7. In Proprietà di sostituzione selezionare la casella di controllo relativa alla sostituzione desiderata e impostare Impostazioni sostituzioni sui valori desiderati. Fare clic su OK. I valori di soglia modificati vengono distribuiti ai server.

Definizione della variabile dell'interfaccia utente di amministrazione di SMS per supportare attività della console

Se il server del sito o l'interfaccia utente di amministrazione di Configuration Manager 2007 si trova in un'installazione di Operations Manager 2007 in cui la gestione di Configuration Manager 2007 è stata importata, la console di Operations Manager potrà avviare i componenti dell'interfaccia utente di Configuration Manager 2007 seguenti dal riquadro attività:

  • Componente di visualizzazione delle risorse
  • Console di Configuration Manager
  • Componente di gestione dei servizi
  • Messaggio di stato

Per avviare queste applicazioni, viene creata una variabile di ambiente di sistema SMS_ADMIN_UI_PATH. Questa variabile di ambiente punta alla directory contenente la console di Configuration Manager, ovvero [PercorsoInstallazioneConfigMgr] \ AdminUI \ bin \ i386 per impostazione predefinita.

Attivazione delle regole di Configuration Manager 2007

Per impostazione predefinita, alcune regole del Management Pack, inclusi i contatori di controllo delle prestazioni e le regole che monitorano la funzionalità di riattivazione LAN (WOL), sono disattivate. Per utilizzare tali regole, è necessario attivarle.

  • Le regole della funzionalità di riattivazione LAN (WOL) disattivate per impostazione predefinita in Configuration Manager 2007 Management Pack sono le seguenti:
  • Soglia prestazioni ConfigMgr 2007: backlog cartella posta in arrivo server del sito WOLCMGR.box > 20 in 1 ora
  • Soglia prestazioni ConfigMgr 2007: backlog cartella posta in arrivo server del sito WOLCMGR.box\data > 100 in 1 ora
  • Soglia prestazioni ConfigMgr 2007: numero totale pacchetti non riusciti componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS > 100 in 15 minuti
  • Soglia prestazioni ConfigMgr 2007: numero totale richieste in sospeso componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS > 10.000 in 3 ore
  • Stato mancante ConfigMgr 2007: componente di sincronizzazione della gestione delle patch - download del catalogo e aggiornamento dei punti di distribuzione con la nuova versione del catalogo completati.
Nota
La regola "Stato mancante ConfigMgr 2007: componente di sincronizzazione della gestione delle patch - download del catalogo e aggiornamento dei punti di distribuzione con la nuova versione del catalogo completati" è supportata solo da Operations Manager 2007 SP1 e versioni successive.

Per attivare una regola del Management Pack disattivata, utilizzare la procedura seguente.

Procedura

Per attivare una regola del Management Pack disattivata

  1. In Operations Console fare clic su Creazione e modifica.

  2. Nel riquadro di spostamento passare a Creazione e modifica > Oggetti Management Pack e quindi fare clic su Regole.

  3. Nel riquadro delle regole cercare la regola da attivare. Se la barra Cerca non è disponibile al di sopra dell'elenco delle regole, passare a Visualizza e quindi fare clic su Trova.

  4. Fare clic con il pulsante destro del mouse sul nome della regola da attivare, passare a Sostituzioni > Sostituisci regola, quindi fare clic sull'insieme di oggetti da monitorare tramite la regola.

  5. Impostare le proprietà Enabled su True e modificare eventualmente le soglie in base all'ambiente in uso. Fare clic su OK.

Vedere anche

Concetti

Guida introduttiva a Configuration Manager 2007 Management Pack
Scenari di monitoraggio del Management Pack per Configuration Manager 2007
Configurazioni supportate per Configuration Manager 2007 Management Pack
Testing e progetto pilota per Configuration Manager 2007 Management Pack

Altre risorse

Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Integrazione di Configuration Manager 2007 con Operations Manager 2007

Configuration Manager 2007 si integra con la console di Operations Manager attraverso le attività della console che avviano i componenti della console di amministrazione di Configuration Manager.

Supporta inoltre l'attivazione della modalità manutenzione nei client Configuration Manager che eseguono l'agente Operations Manager 2007 durante le distribuzione del software e l'esecuzione di programmi di aggiornamento del software. La modalità manutenzione viene inoltre attivata durante il backup del sito, ma in questo caso non è configurabile.

Attività della console di Operations Manager 2007

Le attività della console di amministrazione di Configuration Manager 2007 richiedono l'installazione della console di amministrazione nel computer in cui è installato Operations Console di Operations Manager 2007. È necessario definire la variabile di ambiente SYSTEM denominata SMS_ADMIN_UI_PATH come percorso della cartella contenente il programma della console di Configuration Manager 2007. Per ulteriori informazioni sull'impostazione delle variabili di ambiente di sistema, vedere la pagina Web specifica sull'argomento (http://go.microsoft.com/fwlink/?LinkId=92316).

Dalla console di Operations Manager è possibile avviare le attività di Configuration Manager 2007 seguenti.

Attività | Descrizione
Console di amministrazione di ConfigMgr 2007 | Apre la console di amministrazione di Configuration Manager 2007 per il computer selezionato. Si applica ai computer che ospitano il ruolo server del sito Configuration Manager 2007.
Tutti i messaggi di stato di ConfigMgr 2007 | Richiede il server del sito del computer, apre una finestra MMC ed esegue una query sui messaggi di stato per restituire tutti i messaggi di stato associati al computer selezionato. Si applica a tutti i sistemi.
Gestione dei servizi di ConfigMgr 2007 | Apre il componente di gestione dei servizi di Configuration Manager 2007 per il computer selezionato. Si applica ai computer che ospitano il ruolo server del sito Configuration Manager 2007.
Visualizzazione risorse di ConfigMgr 2007 | Richiede il server del sito del computer, apre una finestra MMC in cui il componente di visualizzazione delle risorse di Configuration Manager 2007 visualizza i dati per il computer selezionato. Si applica a tutti i sistemi.

Modalità manutenzione per Configuration Manager 2007

System Center Configuration Manager 2007 supporta la modalità manutenzione per Operations Manager 2007 con le relative funzionalità di distribuzione e aggiornamento del software. Impostando la modalità manutenzione per l'agente MOM, è possibile eliminare gli avvisi nei computer in cui viene eseguito il client di Configuration Manager.

Quando si distribuiscono programmi nei computer tramite Configuration Manager 2007, è spesso necessario disattivare temporaneamente gli avvisi di Operations Manager basati su regole generati dal computer di destinazione. La distribuzione di aggiornamenti rapidi e patch di protezione su server può ad esempio richiedere la chiusura di thread e servizi. Se i thread o i servizi di tali server sono monitorati da un Management Pack, è possibile che vengano generati numerosi avvisi di Operations Manager che potrebbero sovraccaricare il server Operations Manager.

La casella di controllo Disable MOM alerts while this program runs consente di sospendere la visualizzazione degli avvisi di Operations Manager fino al termine della distribuzione del software. L'amministratore di Configuration Manager 2007 può impostare questa casella di controllo nelle proprietà del programma di Configuration Manager. L'impostazione di questa opzione implica l'eliminazione degli avvisi di Operations Manager per tutti i Management Pack destinati al computer client mentre il computer esegue tale programma. Come timeout per la durata della modalità manutenzione viene utilizzato il massimo tempo di esecuzione consentito.

Attivare la modalità manutenzione per un aggiornamento del software di Configuration Manager

Gli aggiornamenti del software distribuiti da Configuration Manager 2007 possono generare avvisi quando vengono eseguiti su computer client. Per evitare la visualizzazione di avvisi per tali operazioni di manutenzione pianificate, è possibile disattivare gli avvisi per la durata dell'aggiornamento.

Per disattivare gli avvisi di Operations Manager durante l'esecuzione di aggiornamenti software, attenersi alla procedura seguente.

Procedura

Per disattivare gli avvisi di Operations Manager durante l'esecuzione degli aggiornamenti del software

  1. Nella console di Configuration Manager 2007 passare a System Center Configuration Management / Site Database - <nome server sito> / Computer Management / Software Updates / Deployment Management.

  2. Fare clic con il pulsante destro del mouse sul nome dell'aggiornamento e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà programma fare clic sulla scheda Event Generation.

  4. Selezionare Disable Operations Manager alerts while software updates run e quindi fare clic su OK.

Dopo avere attivato la modalità manutenzione per l'aggiornamento software di Configuration Manager, il computer client entrerà in modalità manutenzione durante la distribuzione e l'esecuzione dell'aggiornamento di Configuration Manager.

Attivare la modalità manutenzione per la distribuzione del software di Configuration Manager

La distribuzione di software con Configuration Manager 2007 può generare avvisi quando viene eseguita nei computer client. Per evitare la visualizzazione di avvisi per tali operazioni di manutenzione pianificate, è possibile disattivare gli avvisi per la durata del programma di distribuzione del software.

Per disattivare gli avvisi di Operations Manager durante l'esecuzione del programma di distribuzione del software, attenersi alla procedura seguente.

Procedura

Per disattivare gli avvisi di Operations Manager durante l'esecuzione di un programma di distribuzione del software

  1. Nella console di Configuration Manager 2007 passare a System Center Configuration Management / Site Database - <nome server sito> / Computer Management / Software Distribution / Packages / <NomePacchetto> / Program.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul nome del programma e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà programma fare clic sulla scheda MOM Maintenance Mode.

  4. Selezionare Disable Operations Manager alerts while this program runs e quindi fare clic su OK.

Dopo avere attivato la modalità manutenzione per il programma di Configuration Manager, il computer client entrerà in modalità manutenzione durante la distribuzione e l'esecuzione del pacchetto di Configuration Manager.

Nota
Il timeout della modalità manutenzione viene impostato nella scheda Requirements della finestra di dialogo Proprietà programma dopo avere selezionato la proprietà Maximum allowed runtime.

Generare un avviso per un errore di programma di Configuration Manager 2007

Può risultare necessario inviare un avviso agli amministratori se il programma distribuito da Configuration Manager 2007 non viene installato correttamente nei computer client.

Per generare un avviso di Operations Manager se un programma di distribuzione del software non viene eseguito correttamente, eseguire la procedura seguente.

Procedura

Per generare un avviso di Operations Manager se un programma di distribuzione software del non viene eseguito correttamente

  1. Nella console di Configuration Manager 2007 passare a System Center Configuration Management / Site Database - <nome server sito> / Computer Management / Software Distribution / Packages / <NomePacchetto> / Program.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro sul nome del programma e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà programma fare clic sulla scheda MOM Maintenance Mode.

  4. Selezionare Generate Operations Manager alert if this program fails e quindi fare clic su OK.

Dopo avere attivato questa proprietà, verrà inviato un avviso di Operations Manager nel caso in cui un programma non venga eseguito correttamente.

Generare un avviso per un errore di programma di Configuration Manager 2007

Può risultare necessario inviare un avviso agli amministratori quando il programma distribuito da Configuration Manager 2007 non viene installato correttamente nei computer client.

Per generare un avviso di Operations Manager quando un programma di distribuzione software non viene eseguito correttamente, eseguire la procedura seguente.

Procedura

Per generare un avviso di Operations Manager quando un programma di distribuzione software non viene eseguito correttamente

  1. Nella console di Configuration Manager 2007 passare a System Center Configuration Management / Site Database - <nome server sito> / Computer Management / Software Updates / Deployment.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul nome dell'aggiornamento e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà programma fare clic sulla scheda MOM Maintenance Mode.

  4. Selezionare Generate Operations Manager alert when a software update installation fails e quindi fare clic su OK.

Dopo avere attivato questa proprietà, verrà inviato un avviso di Operations Manager quando l'installazione di un aggiornamento software non verrà eseguita correttamente.

Vedere anche

Concetti

Attività quotidiane per Configuration Manager 2007 Management Pack
Attività settimanali per Configuration Manager 2007 Management Pack
Attività mensili per Configuration Manager 2007 Management Pack

Altre risorse

Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Microsoft® System Center Configuration Manager 2007 Management Pack offre funzionalità nuove e migliorate per il monitoraggio di Configuration Manager 2007. Nelle sezioni seguenti vengono descritti gli scenari principali supportati da Configuration Manager 2007 Management Pack con una descrizione delle rispettive funzionalità.

Disponibilità dei servizi

Individuazione dei servizi

Monitoraggio della disponibilità

Monitoraggio dello stato del computer

Monitoraggio dello stato della gerarchia dei siti

Monitoraggio dello stato dei siti

Supporto per il monitoraggio senza agenti

Monitoraggio delle soglie prestazioni

Monitoraggio delle prestazioni

Monitoraggio dei messaggi di stato critico di Configuration Manager

Monitoraggio dello stato del sistema del sito

Monitoraggio dei dettagli arresto anomalo del servizio Executive

Monitoraggio dei backlog

Monitoraggio dello stato di integrità generale

Monitoraggio della gestione aggiornamenti software di Configuration Manager

Monitoraggio del servizio di backup del sito Configuration Manager

Contenuto della Knowledge Base predefinita relativo a tutti gli avvisi

Gruppi di computer per tutti i ruoli client e server di Configuration Manager

Monitoraggio esteso

Stato di esecuzione del programma di distribuzione software

Monitoraggio delle attività di Configuration Manager

Monitoraggio del file di registro dei componenti

Monitoraggio della posta in arrivo di Configuration Manager 2007

Disponibilità dei servizi

Questo scenario consente di monitorare la disponibilità dei servizi di Configuration Manager mediante l'apposita funzionalità di System Center Operations Manager 2007 e gli eventi del gestore di controllo del servizio nel registro di sistema degli eventi NT. Il monitoraggio della disponibilità dei servizi genera quanto segue:

  • Un avviso in caso di arresto di servizi basati su Configuration Manager nei sistemi del sito Configuration Manager.
  • Un avviso in caso di arresto o di un errore di avvio di un servizio critico dipendente da Configuration Manager, ad esempio Strumentazione gestione Windows (WMI), nei sistemi del sito Configuration Manager.
  • Un avviso in caso di arresto o di un errore di avvio di altri servizi dipendenti da Configuration Manager, ad esempio Microsoft SQL Server™, Internet Information Services (IIS) e Servizio trasferimento intelligente in background, nei sistemi del sito Configuration Manager.
  • Un avviso all'avvio e arresto del servizio di backup del sito di Configuration Manager, affinché sia possibile monitorare la durata dei backup e correlare gli eventi di arresto di altri servizi di Configuration Manager al servizio di backup del sito di Configuration Manager.

Individuazione dei servizi

Questo scenario consiste nell'individuazione di dati, componenti e ruoli server nei computer gestiti. Il processo di individuazione dei servizi restituisce informazioni sui server e i client di Configuration Manager. Supporta inoltre la presentazione dei ruoli client e server di Configuration Manager nelle viste di monitoraggio dello stato.

I dati di individuazione dei servizi specifici del server vengono raccolti e progressivamente visualizzati nella console di System Center Operations Manager dopo la distribuzione del Management Pack a un agente. Le funzionalità che richiedono l'identificazione di ruoli, gruppi di computer e computer di destinazione per attività specifiche non sono disponibili fino alla prima esecuzione della raccolta di dati di individuazione dei servizi.

Configuration Manager Management Pack utilizza la regola di elaborazione degli eventi seguente:

  • ConfigMgr 2007 - individuazione servizi

per avviare gli script di individuazione dei servizi appropriati:

  • ConfigMgr 2007 - individuazione servizi - Server
  • ConfigMgr 2007 - individuazione servizi - Client
  • Gli script utilizzano un provider temporizzato asincrono per raccogliere i dati di individuazione dei servizi una volta ogni 24 ore per impostazione predefinita.

Monitoraggio della disponibilità

In Configuration Manager 2007 Management Pack sono disponibili i report sulla disponibilità seguenti, che consentono di eseguire il monitoraggio dell'heartbeat dei ruoli server seguenti:

  • Disponibilità server ConfigMgr 2007
  • Disponibilità punto di distribuzione ConfigMgr 2007
  • Disponibilità punto di gestione ConfigMgr 2007
  • Disponibilità punto di servizio PXE ConfigMgr 2007
  • Disponibilità server del sito ConfigMgr 2007
  • Disponibilità punto di aggiornamento del software ConfigMgr 2007
  • Disponibilità servizio di convalida dell'integrità di sistema ConfigMgr 2007
  • Disponibilità punto di migrazione dello stato ConfigMgr 2007
  • Disponibilità server di database del sito ConfigMgr 2007

Tutti i report vengono eseguiti con il database di Operations Manager, che consente di specificare la durata del monitoraggio.

Per ulteriori informazioni sui report relativi alla disponibilità del server, vedere Report per Configuration Manager 2007 Management Pack.

Monitoraggio della disponibilità dei ruoli del server

Viene monitorata la disponibilità per i ruoli seguenti:

  • Punto di gestione
  • Punto di gestione del bilanciamento del carico di rete
  • Punto di gestione dei dispositivi
  • Servizio di convalida dell'integrità di sistema
  • Punto di migrazione dello stato
  • Punto di servizio PXE
  • Punto di aggiornamento del software
  • Punto di distribuzione
  • Server di database del sito

Monitoraggio della disponibilità dei componenti

Viene eseguito il monitoraggio della disponibilità per i componenti seguenti e viene generato periodicamente un heartbeat che ne segnala lo stato della disponibilità:

  • Componente di gestione della posta in arrivo
  • Servizio di monitoraggio della posta in arrivo
  • Servizio di gestione dei componenti del sito
  • Componente di gestione del controllo del punto di gestione
  • Componente di gestione dell'invio di file del punto di gestione
  • Servizio di monitoraggio della posta in uscita
  • Componente di gestione delle comunicazioni di riattivazione LAN (WOL)
  • Componente di gestione di riattivazione LAN (WOL)
  • Componente di gestione della configurazione WSUS
  • Componente di gestione della sincronizzazione WSUS
  • Componente di gestione del controllo WSUS
  • Servizio di monitoraggio delle notifiche del database
  • Generatore riepilogo dello stato delle offerte
  • Generatore riepilogo dello stato dei componenti
  • Generatore riepilogo dello stato del sistema del sito
  • Servizio di monitoraggio dei componenti
  • Punto di migrazione dello stato
  • Punto di servizio PXE

Monitoraggio dello stato del computer

Il monitoraggio dello stato del computer consente di visualizzare in una tabella lo stato di integrità di tutti i client e i server di Configuration Manager. I ruoli e i componenti server vengono gestiti tramite l'individuazione dei servizi. Lo stato di integrità dei componenti viene gestito tramite un insieme di regole e di monitoraggi.

Nella tabella seguente vengono indicati gli stati di integrità monitorati per i componenti di Configuration Manager in base al colore corrispondente.

Monitoraggio dello stato dei server Configuration Manager

Componente server ConfigMgr | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Server del sito (SS) | Sì | Sì | Sì
Punto di gestione (MP) | Sì | Sì | Sì
Database del sito (DB) | Sì | Sì | Sì
Punto di distribuzione (DP) | Sì |  | Sì
Punto di localizzazione del server (SLP) | Sì |  | Sì
Punto di reporting (RP) | Sì |  | Sì
Punti di migrazione dello stato (SMP) | Sì | Sì | Sì
Punti di servizio PXE (PSP) | Sì | Sì | Sì
Punti dello stato di fallback (FSP) | Sì | Sì | Sì
Servizio di convalida dell'integrità di sistema (SHV) | Sì | Sì | Sì
Punti di aggiornamento del software (SUP) | Sì | Sì | Sì
Provider |  |  |
Prestazioni | Sì | Sì | Sì

Monitoraggio dello stato dei client di Configuration Manager

Componente client ConfigMgr | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Servizio client | Sì |  | Sì

Monitoraggio dello stato della gerarchia dei siti

Il monitoraggio dello stato della gerarchia dei siti consente di visualizzare in una tabella l'integrità di tutti i sistemi gestiti di Configuration Manager 2007 nella gerarchia dei siti. Lo stato di integrità dei componenti viene gestito tramite un insieme di regole e di monitoraggi.

Nella tabella seguente vengono indicati gli stati di integrità monitorati per i sistemi di Configuration Manager in base al colore corrispondente.

Monitoraggio dello stato della gerarchia dei siti di Configuration Manager

Componente server ConfigMgr | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Disponibilità | Sì | Sì | Sì
Prestazioni | Sì | Sì | Sì

Monitoraggio dello stato dei siti

Il monitoraggio dello stato dei siti consente di visualizzare in una tabella l'integrità di tutti i server gestiti di Configuration Manager. Lo stato di integrità viene gestito tramite un insieme di regole e di monitoraggi.

Nella tabella seguente vengono indicati gli stati di integrità monitorati per gli stati dei siti Configuration Manager in base al colore corrispondente.

Monitoraggio dello stato dei siti Configuration Manager

Componente server ConfigMgr | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Disponibilità | Sì | Sì | Sì
Prestazioni | Sì | Sì | Sì

Supporto per il monitoraggio senza agenti

Configuration Manager Management Pack supporta il monitoraggio su computer gestiti senza agenti, a eccezione delle funzionalità seguenti:

  • Monitoraggio dei messaggi di stato critico di Configuration Manager
  • Monitoraggio dello stato del sistema del sito

Gli script seguenti supportano le funzionalità indicate sopra:

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks

Per poter accedere alle risorse di Configuration Manager, è necessario che gli script vengano eseguiti a livello locale. Se gli script non riescono ad accedere a una risorsa, verranno generati un errore di script e un avviso.

Monitoraggio delle soglie prestazioni

Livelli di prestazioni ridotti possono determinare ritardi e influenzare negativamente i contratti di servizio degli utenti in termini di tempo, prestazioni e accuratezza dei dati. È importante individuare e risolvere i problemi gravi relativi alle prestazioni nell'infrastruttura di Configuration Manager. Il monitoraggio delle soglie prestazioni genera un avviso in caso di superamento dei livelli seguenti nella condizione sottoposta a monitoraggio:

  • Metriche relative all'integrità a livello di computer per quanto concerne CPU, file di paging e memoria nei sistemi del sito Configuration Manager.
  • Numero totale di file di Configuration Manager, ad esempio processi del componente di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR) e record di inventario software e hardware, nelle cartelle di posta in arrivo del server del sito Configuration Manager.
  • Numero totale di messaggi di Configuration Manager relativi allo stato, ai record dei dati di individuazione, all'inventario software e hardware nelle code dei messaggi dei punti di gestione di Configuration Manager.
  • Risposte e condizioni del servizio di convalida dell'integrità di sistema (SHV).
  • File nelle cartelle posta in uscita SMS.
  • Richieste del punto di servizio PXE (PSP).
  • Client e spazio su disco totali del punto di migrazione dello stato (SMP).
  • Pacchetti di riattivazione LAN (WOL)

Monitoraggio delle prestazioni

Questo scenario consente di controllare le tendenze nei backlog, nelle velocità di elaborazione e nei conteggi totali degli oggetti chiave di Configuration Manager allo scopo di individuare e risolvere attivamente i problemi. Questo tipo di monitoraggio consente di controllare graficamente le tendenze seguenti mediante le viste e i report di Operations Manager 2007:

  • File di backlog nelle cartelle di posta in arrivo riguardanti i processi del componente di pianificazione, le richieste di invio, i record di controllo software, i record dei dati di individuazione, l'inventario hardware, l'inventario software, i pacchetti di riattivazione LAN (WOL) e i messaggi di stato e sullo stato attuale nei server del sito Configuration Manager.
  • Velocità di elaborazione relative ai processi del componente di pianificazione, alle richieste di invio, ai record di controllo software, ai record dei dati di individuazione, all'inventario hardware, all'inventario software, ai pacchetti di riattivazione LAN (WOL), agli aggiornamenti dei punti di aggiornamento del software (SUP) e ai messaggi di stato e sullo stato attuale nei server del sito Configuration Manager.
  • Numero totale dei processi del componente di pianificazione, delle richieste di invio, dei record di controllo software, dei record dei dati di individuazione, dei file inventario hardware e software, dei pacchetti di riattivazione LAN (WOL), degli aggiornamenti dei punti di aggiornamento del software (SUP) e dei messaggi di stato e sullo stato attuale nei server del sito Configuration Manager.
  • Backlog di messaggi relativi a record dei dati di individuazione, inventario hardware, inventario software, controllo software, messaggi di stato e sullo stato attuale e altri oggetti di Configuration Manager nelle code dei messaggi dei server dei punti di gestione di Configuration Manager.
  • Velocità di elaborazione relative a record dei dati di individuazione, inventario hardware, inventario software, controllo software, messaggi di stato e sullo stato attuale, richieste di pacchetti SDM e altri oggetti di Configuration Manager nelle code dei messaggi dei server dei punti di gestione di Configuration Manager.
  • Numero totale di record dei dati di individuazione, file inventario hardware e software, inoltri, richieste di pacchetti SDM e messaggi di stato nelle code dei messaggi dei server dei punti di gestione di Configuration Manager.
  • Metriche relative all'integrità a livello di computer per quanto concerne CPU, file di paging e memoria nei sistemi del sito Configuration Manager.
  • Numero totale di thread del servizio Configuration Manager Executive in esecuzione.
  • Frequenza delle richieste di estensione ISAPI a IIS.
  • Backlog nelle cartelle di posta in uscita nei sistemi del sito.
  • Richieste di disponibilità server SMS.
  • Condizione del servizio di convalida dell'integrità sistema e richieste del rapporto di integrità.
  • Elaborazione delle richieste del punto di servizio PXE.
  • Elaborazione dello stato e spazio libero su disco dei client del punto di migrazione dello stato.
  • Velocità di elaborazione di record dei dati di individuazione, inventario hardware, inventario software, controllo software, messaggi di stato e altri oggetti di Configuration Manager nelle code dei messaggi dei server dei punti di gestione dei dispositivi di Configuration Manager.

Monitoraggio dei messaggi di stato critico di Configuration Manager

L'infrastruttura di Configuration Manager genera messaggi di stato. È importante individuare i messaggi di stato critico di Configuration Manager relativi ai server e risolverli tempestivamente. Tali messaggi indicano in genere problemi in termini di disponibilità, prestazioni, protezione, configurazione e stato generale di integrità dell'infrastruttura di Configuration Manager.

Questo tipo di monitoraggio genera un avviso quando vengono rilevati messaggi di stato critico relativi a Configuration Manager, ad esempio per installazioni di componenti, connettività del database e del sito. La presenza di messaggi di stato critico di Configuration Manager viene controllata nel database del sito Configuration Manager ogni mezz'ora in modo sincrono all'ora.

Monitoraggio dello stato del sistema del sito

Configuration Manager controlla regolarmente lo stato di integrità di base dei sistemi del sito tramite il generatore del riepilogo dello stato del sistema del sito, che esegue il polling dei sistemi del sito Configuration Manager allo scadere di ogni ora. Per sfruttare al meglio i vantaggi di questa funzionalità, è necessario agire rapidamente sullo stato in modo da impedire riduzioni di funzionalità di Configuration Manager. Questo tipo di monitoraggio consente di controllare e generare avvisi quando il generatore del riepilogo dello stato del sistema del sito rileva uno stato critico del sistema del sito Configuration Manager. Uno stato critico può verificarsi, ad esempio, quando un sistema del sito Configuration Manager è inattivo oppure quando inizia a esaurirsi lo spazio nel database o per i registri in un server SQL Server o lo spazio fisico su disco delle unità NTFS nei sistemi del sito Configuration Manager.

Monitoraggio dei dettagli arresto anomalo del servizio Executive

Gli errori del servizio Configuration Manager Executive influiscono sulla disponibilità di Configuration Manager ed è importante sapere quando si verificano gli arresti anomali e analizzarne le cause principali. Quando si verifica un problema nel servizio SMS Executive, viene creata una sottodirectory del registro dei dettagli arresto anomalo nella directory <PercorsoInstallazioneConfigMgr>\Logs\CrashDumps. La creazione di questa sottodirectory viene monitorata e viene generato un avviso per qualsiasi ruolo server Configuration Manager dipendente dal servizio SMS Executive.

Lo script Monitor SMS Executive Crash Dumps di Configuration Manager 2007 segnala solo gli arresti anomali più recenti. Ciò si applica indipendentemente dal tempo trascorso dall'ultimo arresto anomalo, a partire dalla prima esecuzione dello script fino all'eventuale disinstallazione e successiva reinstallazione di SMS Executive.

Le regole correlate vengono applicate alla classe Server del componente Microsoft ConfigMgr 2007 basati su SMS Executive:

  • Dettagli arresto anomalo ConfigMgr 2007: monitoraggio SMS Executive

Dettagli arresto anomalo ConfigMgr 2007: monitoraggio SMS Executive avvia lo script ogni 60 minuti per eseguire la sincronizzazione alle 00.10. Le informazioni di riepilogo sono disponibili nella pagina delle proprietà Knowledge Base predefinita della regola.

  • Dettagli arresto anomalo ConfigMgr 2007: errore script di monitoraggio SMS Executive

Dettagli arresto anomalo ConfigMgr 2007: errore script di monitoraggio SMS Executive controlla eventuali eventi di errore di script e genera appositi avvisi. Esiste un solo evento di errore di script, il numero 1102, che segnala tutti gli errori di script. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge Base predefinita della regola.

  • Dettagli arresto anomalo ConfigMgr 2007: arresto anomalo di SMS Executive

Dettagli arresto anomalo ConfigMgr 2007: arresto anomalo di SMS Executive controlla gli eventi di arresto anomalo e genera gli appositi avvisi. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge Base predefinita della regola.

Monitoraggio dei backlog

I backlog determinano ritardi che influenzano i contratti di servizio degli utenti in termini di tempo, prestazioni e accuratezza dei dati. È importante individuare e risolvere tempestivamente i problemi gravi relativi alle prestazioni nell'infrastruttura di Configuration Manager. Viene generato un avviso quando un backlog supera una soglia in un periodo di tempo specifico relativamente a quanto segue:

  • Numero totale di file di Configuration Manager, ad esempio processi del componente di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR), record di inventario software e hardware, richieste di riattivazione LAN (WOL) e messaggi di stato e sullo stato attuale nelle cartelle di posta in arrivo del server del sito Configuration Manager.
  • Numero totale di oggetti di Configuration Manager, ad esempio processi del componente di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR), record di inventario software e hardware, richieste di riattivazione LAN (WOL) e messaggi di stato nelle code dei messaggi del server del sito Configuration Manager.
  • Numero totale di messaggi di Configuration Manager relativi allo stato, ai record dei dati di individuazione, all'inventario software e hardware nelle code dei messaggi dei punti di gestione di Configuration Manager.
  • Numero totale di file, ad esempio record di controllo software, record dei dati di individuazione (DDR), record di inventario software e hardware e messaggi di stato e sullo stato attuale nelle cartelle di posta in uscita del sistema del sito.

Monitoraggio dello stato di integrità generale

Questo tipo di monitoraggio genera un avviso quando una metrica relativa allo stato di integrità in un server Configuration Manager supera una determinata soglia in un periodo di tempo specifico. Vengono monitorate le metriche seguenti:

  • Tempo processore al 95% in tre ore
    • Smsexec
    • Ccmexec
    • Totale
  • Utilizzo file di paging al 98% in tre ore

Monitoraggio della gestione aggiornamenti software di Configuration Manager

Gli amministratori di Configuration Manager fanno affidamento sulle funzionalità di gestione degli aggiornamenti software di Configuration Manager per distribuire gli aggiornamenti della protezione più recenti nei computer server e client delle rispettive organizzazioni. Il monitoraggio della gestione delle patch consente di rilevare eventuali errori nella configurazione e nell'elaborazione della gestione degli aggiornamenti software di Configuration Manager. Viene generato un avviso quando si verificano le situazioni seguenti:

  • Non è possibile configurare il server WSUS.
  • Configuration Manager non è in grado di sottoscrivere gli aggiornamenti dal server WSUS.
  • Il processo di sincronizzazione della gestione aggiornamenti software di Configuration Manager non riesce.
  • Il processo di gestione degli aggiornamenti software di Configuration Manager non è in grado di fornire gli aggiornamenti ai punti di distribuzione di Configuration Manager.

Monitoraggio del servizio di backup del sito Configuration Manager

Conoscendo gli orari di avvio, completamento o errore del servizio di backup di Configuration Manager, gli amministratori possono controllare le attività di backup, ad esempio pianificare l'esecuzione periodica di backup dei dati, dei criteri e delle configurazioni di Configuration Manager.

È importante monitorare gli errori del processo di backup e adottare le necessarie azioni correttive. Anche in caso di esito positivo, il processo di backup di Configuration Manager influisce sulla disponibilità dei servizi poiché determina l'arresto e il riavvio del servizio di gestione dei componenti del sito SMS e del servizio SMS Executive. Il monitoraggio del servizio di backup di Configuration Manager consente di tenere traccia dei tempi di inattività di tali servizi poiché gli avvisi relativi al loro arresto vengono sospesi durante il processo di backup. A questo tipo di monitoraggio vengono applicate le regole seguenti:

  • Stato ConfigMgr 2007: backup del sito completato
  • Stato ConfigMgr 2007: backup del sito non riuscito
  • Stato ConfigMgr 2007: servizio di backup del sito - impossibile avviare il processo di backup fino al completamento dell'attività di backup in corso
  • Stato ConfigMgr 2007: servizio di backup del sito - il percorso di backup SQL risulta vuoto o non valido
  • Interruzione servizio ConfigMgr 2007: SMS_SITE_BACKUP
  • Avvio servizio ConfigMgr 2007: SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: interruzione imprevista di SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: blocco all'avvio di SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: impossibile avviare SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: accesso di SMS_SITE_BACKUP non riuscito
  • Errore servizio ConfigMgr 2007: SMS_SITE_BACKUP dipende da un altro servizio che non è stato possibile avviare o che non esiste

  • Servizio ConfigMgr 2007 in esecuzione: SMS_SITE_VSS_WRITER
  • Errore servizio ConfigMgr 2007: interruzione imprevista di SMS_SITE_VSS_WRITER
  • Errore servizio ConfigMgr 2007: blocco all'avvio di SMS_SITE_VSS_WRITER
  • Errore servizio ConfigMgr 2007: impossibile avviare SMS_SITE_VSS_WRITER
  • Errore servizio ConfigMgr 2007: accesso di SMS_SITE_VSS_WRITER non riuscito
  • Errore servizio ConfigMgr 2007: SMS_SITE_VSS_WRITER dipende da un altro servizio che non è stato possibile avviare o che non esiste

Contenuto della Knowledge Base predefinita relativo a tutti gli avvisi

Gli amministratori possono fare riferimento al contenuto della Knowledge Base predefinita relativo a tutti gli avvisi allo scopo di ottenere informazioni utili per l'identificazione e la risoluzione dei problemi. Per accedere a tale contenuto, fare clic con il pulsante destro del mouse su una regola qualsiasi, scegliere Proprietà e quindi fare clic sulla scheda Knowledge Base predefinita.

Gruppi di computer per tutti i ruoli client e server di Configuration Manager

I gruppi di computer sono associati a ruoli client e server specifici di Configuration Manager. L'assegnazione delle regole e dei monitoraggi è basata su classi anch'esse associate ai ruoli client e server di Configuration Manager. In questo modo gli amministratori dispongono di un livello di controllo appropriato per l'assegnazione delle regole del Management Pack.

Monitoraggio esteso

Le regole disponibili in Configuration Manager Management Pack consentono di eseguire le attività di monitoraggio di base relative ai servizi, alle soglie prestazioni e alla misurazione di queste ultime per le tecnologie dipendenti, ovvero SQL Server, IIS, BITS, il sistema operativo Windows, WMI, WSUS, Servizi di distribuzione Windows e Trivial FTP. In alcuni casi il supporto è disattivato per impostazione predefinita. È possibile attivare e utilizzare il supporto limitato in Configuration Manager Management Pack, ma è consigliabile importare e utilizzare i Management Pack per i prodotti specifici.

  • Utilizzare SQL Server Management Pack per estendere il monitoraggio dei server di database del sito Configuration Manager, dei punti di gestione con database del sito replicato e dei punti di aggiornamento del software con dipendenze da SQL Server.
  • Utilizzare IIS Management Pack per monitorare IIS nei punti di reporting, nei punti di gestione, nei punti di localizzazione del server, nei punti di migrazione dello stato e nei punti dello stato di fallback. IIS Management Pack è inoltre in grado di monitorare i punti di distribuzione in cui è attivato il server BITS.
  • Utilizzare Microsoft Windows Operating System Management Pack per monitorare i componenti di base di Windows, quali statistiche su memoria, CPU e dischi.

Altri Management Pack, per i quali Configuration Manager 2007 Management Pack non include regole, consentono di migliorare il monitoraggio dell'infrastruttura di Configuration Manager.

  • Utilizzare il Management Pack di Bilanciamento carico di rete di Windows se si utilizza Bilanciamento carico di rete per supportare più punti di gestione nella gerarchia Configuration Manager per motivi di scalabilità.
  • Utilizzare Windows Active Directory® Management Pack per monitorare lo stato di integrità dell'infrastruttura Active Directory.

Se si distribuiscono più Management Pack nell'ambiente in uso, potrebbero essere generati avvisi ridondanti a seconda delle regole esistenti nei Management Pack stessi. Se si disattivano le regole di monitoraggio ridondanti, l'accuratezza delle viste sullo stato relative ai Management Pack distribuiti potrebbe risentirne. È necessario valutare con attenzione i vantaggi e gli svantaggi della ricezione di avvisi ridondanti e mantenere attivo il monitoraggio dello stato per tutti i Management Pack distribuiti. A seconda dei Management Pack aggiuntivi che vengono distribuiti, è consigliabile esaminare le regole ridondanti per identificare quelle che possono essere eventualmente attivate nell'ambiente in uso. Dopo l'installazione dei Management Pack, verificare che essi siano personalizzati in base alle necessità, configurati correttamente e che le regole appropriate siano attivate.

Stato di esecuzione del programma di distribuzione software

Il client di Configuration Manager è in grado di segnalare errori dei programmi tramite il Management Pack.

Gli amministratori possono selezionare la casella di controllo Generate Operations Manager alert if this program fails nella scheda MOM Maintenance Mode della finestra di dialogo Proprietà programma.

Procedura

Per attivare gli avvisi di Operations Manager 2007 in caso di errore di un programma Configuration Manager 2007, è necessario eseguire la procedura seguente:

Per attivare gli avvisi di Operations Manager 2007 per un programma Configuration Manager

  1. Nella console di Configuration Manager passare a System Center Configuration Manager / Site Database - <nome server del sito> / Gestione computer / Distribuzione software / Pacchetti / <Nome pacchetto> / Programmi.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul programma e scegliere Proprietà.

  3. Fare clic sulla scheda MOM Maintenance Mode.

  4. Selezionare la casella di controllo Generate Operations Manager alert if this program fails to run. Fare clic su OK.

Monitoraggio delle attività di Configuration Manager

Le attività eseguite con il database del sito Configuration Manager, ad esempio la valutazione delle raccolte, il riepilogo dei messaggi sullo stato attuale e la manutenzione del sito, vengono tutte monitorate in relazione allo stato di completamento e alla durata. Se un'attività genera un errore o supera la durata massima prevista, verrà generato un avviso.

Monitoraggio del file di registro dei componenti

Le regole seguenti sono basate sul monitoraggio dei file sender.log, distmgr.log e policypv.log:

  • Componente SMSv4: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione standard).
  • Componente SMSv4: il server Sender non è in grado di connettersi al sito remoto tramite la connessione RAS.
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione avanzata)
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile elaborare un pacchetto
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile inserire un pacchetto SMS perché il contenuto di tipo SDM non è presente nella tabella CI_Contents.
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di aggiornamento software dal database di sito SMS
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di aggiornamento software
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di conformità dal database di sito SMS
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di conformità
  • Componente ConfigMgr 2007: provider di criteri - impossibile inviare notifica di una modifica dei criteri al componente di gestione della gerarchia

Monitoraggio della posta in arrivo di Configuration Manager 2007

La maggior parte delle più importanti attività sul lato server viene eseguita da Configuration Manager leggendo dai file e scrivendo nei file nelle relative cartelle di posta in arrivo. Quando le cartelle di posta in arrivo di Configuration Manager 2007 sono insolitamente piene, significa che il processo di elaborazione di Configuration Manager 2007 è rallentato. Questo problema può essere dovuto a diversi motivi, ad esempio file non validi, processi interrotti, spazio su disco insufficiente o livello insolito di attività di distribuzione software. I problemi di questo tipo sono rari, ma piuttosto gravi per i clienti con un considerevole numero di siti.

Un servizio di monitoraggio della posta in arrivo eseguito come thread del servizio SMS Executive consente di monitorare il numero di elementi aggiunti alla coda dal componente del servizio e non il numero effettivo di elementi in attesa di essere elaborati nel disco.

Tutte le regole si trovano nella classe di installazione di elaborazione ConfigMgr 2007 Site Servers – Common, tramite la quale queste regole vengono applicate ai siti centrale, primario e secondario.

Pianificazione e configurazione facoltativa

Per ridurre al minimo l'impatto del monitoraggio delle cartelle di posta in arrivo sulle prestazioni, le regole pertinenti vengono sincronizzate per essere eseguite una volta al giorno. Le regole vengono scaglionate a intervalli di 15 minuti, a iniziare dalle ore 1.00, in modo che venga eseguita una sola regola per volta. Tramite la prima regola vengono ad esempio contati i file presenti nella prima cartella di posta in arrivo alle ore 1.00. Tramite la regola successiva vengono contati i file presenti nella seconda cartella di posta in arrivo alle ore 1.15 e così via, fino a completare il conteggio per tutte le cartelle di posta in arrivo.

È possibile modificare questa pianificazione seguendo i passaggi utilizzati in genere per pianificare l'esecuzione degli script di regole in Operations Manager 2007. Per attivare questa funzionalità non è necessaria alcuna configurazione iniziale. Di seguito sono elencate le modifiche che è possibile apportare alla configurazione:

  • Modifica del valore di soglia predefinito per ogni cartella di posta in arrivo.
  • Modifica della pianificazione per le singole regole per le cartelle di posta in arrivo.

Queste modifiche facoltative alla configurazione possono essere apportate seguendo i passaggi utilizzati in genere per configurare le regole per gli eventi di soglia in qualsiasi Management Pack.

Avvisi e valori di soglia

Quando viene elaborata una regola di monitoraggio, viene generato un avviso ogni volta che viene raggiunto il valore soglia configurato per una regola specifica per le cartelle di posta in arrivo.

Per modificare i valori di soglia delle prestazioni

  1. Nella console di amministrazione di Operations Manager 2007 fare clic su Creazione e modifica.

  2. Nel riquadro Creazione e modifica passare a Creazione e modifica > Oggetti Management Pack > Monitoraggi.

  3. Nel riquadro Monitoraggi cercare Server ConfigMgr.

  4. Passare a Server ConfigMgr > Entity Health > Availability e quindi espandere i ruoli server seguenti da modificare:

    • DB - Server database
    • DP - Punti di distribuzione
    • FSP - Punti dello stato di fallback
    • MP - Server del punto di gestione
    • PSP - Punti di servizio PXE
    • SS - Server del sito
    • Provider - Provider
    • RP - Punti di reporting
    • SHV - Servizi di convalida dell'integrità di sistema
    • SLP - Punti di localizzazione del server
    • SMP - Punti di migrazione dello stato
    • SUP - Punti di aggiornamento del software

  5. Fare clic con il pulsante destro del mouse sul servizio di monitoraggio per il quale si desidera modificare le prestazioni, passare a Sostituzioni > Override the Monitor e quindi fare clic sulla categoria di oggetti alla quale verrà applicata la sostituzione.

  6. Selezionare le caselle di controllo desiderate per configurare le Proprietà di sostituzione del servizio di monitoraggio in modo da adattarle all'ambiente in uso. Fare clic su OK.

Per ulteriori informazioni sulle cartelle della posta in arrivo e le relative modalità di utilizzo in Configuration Manager, vedere la pagina Web dedicata a questo argomento (http://go.microsoft.com/fwlink/?LinkId=99539).

Vedere anche

Altre risorse

Distribuzione di Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack


Esecuzione di attività operative per Configuration Manager 2007 Management Pack

È consigliabile analizzare e risolvere tutti gli avvisi per identificare quelli più importanti o critici. È inoltre consigliabile eseguire regolarmente altre attività a seconda dell'ambiente in uso. Numerosi problemi importanti non generano avvisi, ma richiedono un'attenzione periodica. System Center Configuration Manager 2007 Management Pack include viste e report che consentono di visualizzare i dati in un lasso di tempo e offrono modelli che indicano problemi. Analizzare viste e report per risolvere i problemi prima che vengano generati avvisi.

È consigliabile eseguire attività quotidiane, settimanali e mensili, come indicato in questa sezione, regolandone tuttavia la frequenza in base alle esigenze dell'ambiente in uso.

Per ulteriori informazioni sulla gestione di Configuration Manager 2007, vedere la pagina Web relativa alla manutenzione di Configuration Manager 2007 (http://go.microsoft.com/fwlink/?LinkId=102324). Per ulteriori informazioni sulla gestione dei siti, vedere la panoramica sulla manutenzione dei siti (http://go.microsoft.com/fwlink/?LinkId=102325).

In questa sezione

Attività quotidiane per Configuration Manager 2007 Management Pack

Attività settimanali per Configuration Manager 2007 Management Pack

Attività mensili per Configuration Manager 2007 Management Pack

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack per Configuration Manager 2007
Integrazione di Configuration Manager 2007 con Operations Manager 2007

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack
Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Attività quotidiane per Configuration Manager 2007 Management Pack

È consigliabile eseguire le attività seguenti ogni giorno:

  • Verificare l'appartenenza al gruppo di computer.
  • Verificare che tutti gli agenti Operations Manager 2007 comunichino con il server Operations Manager 2007.
  • Controllare la vista dello stato della gerarchia del sito.
  • Controllare la vista dello stato del sito.
  • Verificare il diagramma della gerarchia del sito.
  • Esaminare tutti gli avvisi aperti. Espandere in Esplora stati le viste o i diagrammi.
  • Esaminare i backlog delle prestazioni.
  • Esaminare le frequenze di elaborazione delle prestazioni.
  • Controllare le prestazioni del server e degli agenti Operations Manager 2007.
  • Se si esegue il backup del sito ConfigMgr quotidianamente, controllare lo stato e i file di backup.
  • Esaminare gli eventi (facoltativo).

Esaminare tutti gli avvisi aperti

Molti degli avvisi di Configuration Manager 2007 Management Pack vengono visualizzati nel formato descrittivo seguente:

$Computer$ <Rule Name>

$Description$

Event details

Esaminare tutti gli avvisi in Operations Manager 2007 per accertarsi che siano stati risolti tempestivamente. Per esaminare gli avvisi aperti, è possibile utilizzare uno o più dei metodi seguenti:

  • In Operations Console fare clic sul pulsante Monitoraggio, espandere Microsoft System Center Configuration Manager 2007 e fare clic su Avvisi.
  • In Operations Console fare clic sul pulsante Monitoraggio, espandere Microsoft System Center Configuration Manager 2007 e fare clic su Generale. Selezionare la categoria degli avvisi generati nelle ultime 72 ore.
  • Gli avvisi possono essere visualizzati per computer o gruppo di computer facendo clic su Creazione e modifica e selezionando Gruppi. Fare clic con il pulsante destro del mouse sul gruppo di computer di Configuration Manager 2007 che si desidera esaminare, selezionare Vista stato, quindi Open Alerts.
  • È possibile visualizzare gli avvisi tramite la vista dello stato del computer, che include un elenco di computer con le relative classi rilevate. Fare clic con il pulsante destro del mouse su uno dei computer, quindi scegliere Vista avvisi per ottenere un elenco degli avvisi correnti ordinati in base alla gravità.
  • È possibile visualizzare gli avvisi tramite la vista dello stato dei siti. Nella vista dello stato dei siti viene visualizzato un elenco di siti con le relative classi rilevate. Fare clic con il pulsante destro del mouse su uno dei siti, quindi scegliere Vista avvisi ottenere un elenco degli avvisi correnti ordinati in base alla gravità.
  • È possibile visualizzare gli avvisi tramite la vista dello stato della gerarchia dei siti. Nella vista dello stato della gerarchia dei siti sono visualizzati la gerarchia dei siti con le relative classi rilevate. Fare clic con il pulsante destro del mouse sull'istanza della gerarchia, quindi scegliere Vista avvisi per ottenere un elenco degli avvisi correnti ordinati in base alla gravità.
  • È possibile visualizzare gli avvisi tramite la vista dei diagramma dello stato della gerarchia. In tale vista vengono visualizzati una rappresentazione grafica della gerarchia dei siti Configuration Manager 2007. Fare clic con il pulsante destro del mouse su uno degli oggetti del diagramma, quindi scegliere Vista avvisi per ottenere un elenco degli avvisi correnti ordinati in base alla gravità.

È consigliabile esaminare tutti i nuovi avvisi nell'ordine seguente:

  1. Avvisi di errori di installazione di Configuration Manager 2007
  2. Avvisi dei principali servizi di Configuration Manager 2007
  3. Avvisi dei servizi secondari di Configuration Manager 2007
  4. Avvisi di errori di script di Configuration Manager 2007
  5. Avvisi dei ruoli del server di Configuration Manager 2007
  6. Avvisi dei componenti di Configuration Manager 2007
  7. Avvisi basati sul generatore riepilogo dello stato del sistema del sito di Configuration Manager 2007
  8. Avvisi basati sui messaggi di stato di Configuration Manager 2007
  9. Avvisi relativi alla soglia di prestazioni di Configuration Manager 2007
  10. Avvisi di monitoraggio della posta in arrivo di Configuration Manager 2007
  11. Avvisi di monitoraggio della posta in uscita di Configuration Manager 2007
  12. Avvisi di monitoraggio delle attività di Configuration Manager 2007
  13. Avvisi di errori di backup del sito Configuration Manager 2007
  14. Avvisi di errori del programma di Configuration Manager 2007

Verificare l'appartenenza al gruppo di computer

È possibile verificare l'appartenenza al gruppo di computer mediante Operations Manager 2007.

In Operations Console fare clic sul pulsante Creazione e modifica, selezionare Gruppi e quindi fare clic con il pulsante destro del mouse sul gruppo di computer Microsoft Configuration Manager 2007 appropriato. Verificare che ognuno dei gruppi di computer visualizzati contenga i computer corretti.

Verificare che gli agenti comunichino con il server Operations Manager 2007

Gli errori di comunicazione tra l'agente e l'infrastruttura di monitoraggio impediscono la ricezione degli avvisi. Verificare che l'agente e il server in cui viene eseguito Operations Manager 2007 comunichino controllando che lo stato di integrità dei server Configuration Manager nella vista dello stato del computer non sia disattivato.

Esaminare i backlog e le frequenze di elaborazione delle prestazioni

I backlog e le frequenze di elaborazione delle prestazioni risultano particolarmente utili per rilevare tendenze quotidiane ed esaminare la gerarchia di Configuration Manager. È possibile visualizzare i backlog e le frequenze di elaborazione delle prestazioni in Operations Manager 2007.

Per visualizzare i backlog delle prestazioni

Per visualizzare i backlog delle prestazioni, eseguire la procedura seguente:

Per visualizzare i backlog delle prestazioni

  1. In Operations Console fare clic su Monitoraggio e quindi espandere Microsoft System Center Configuration Manager 2007.

Espandere Prestazioni e quindi Backlog. Successivamente fare clic sulla sottocartella e sulla visualizzazione del ruolo del server appropriato. Fare clic sul pulsante Mostra per specificare i computer visualizzati nel grafico del contatore.

Per visualizzare le velocità di elaborazione delle prestazioni

Per visualizzare le velocità di elaborazione delle prestazioni, eseguire la procedura seguente:

Per visualizzare le velocità di elaborazione delle prestazioni

  1. In Operations Console fare clic su Monitoraggio e quindi espandere Microsoft System Center Configuration Manager 2007.

  2. Espandere Prestazioni e quindi Velocità di elaborazione. Successivamente fare clic sulla sottocartella e sulla visualizzazione del ruolo del server appropriato. Fare clic sulle caselle di controllo Mostra per specificare i computer visualizzati nel grafico del contatore.

Per visualizzare le condizioni delle prestazioni

Per visualizzare le condizioni delle prestazioni, eseguire la procedura seguente:

Per visualizzare le condizioni delle prestazioni

  1. In Operations Console fare clic su Monitoraggio e quindi espandere Microsoft System Center Configuration Manager 2007.

  2. Espandere Prestazioni e quindi Condizioni. Successivamente fare clic sulla sottocartella e sulla visualizzazione del ruolo del server appropriato. Fare clic sulle caselle di controllo Mostra per specificare i computer visualizzati nel grafico del contatore.

Monitoraggio dei backup di Configuration Manager 2007

È consigliabile attivare l'attività di manutenzione servizio di backup del sito di Configuration Manager 2007 e pianificare i backup in base alle esigenze dell'ambiente aziendale. Il processo del servizio di backup del sito di Configuration Manager supporta VSS ma non i backup in fase di esecuzione durante i processi seguenti:

  • Copia di parti della cartella di installazione di Configuration Manager nel percorso di esportazione di backup
  • Backup dei diversi valori del Registro di sistema di Configuration Manager
  • Backup del database di sito Configuration Manager in un server che esegue Microsoft SQL Server™

Al termine del backup tutti i servizi SMS vengono riavviati. L'arresto e l'avvio di tali servizi sono eventi normali durante il processo di backup e non indicano la presenza di errori gravi. Gli avvisi che verrebbero normalmente visualizzati a causa dell'arresto di tali servizi vengono ignorati durante il backup del sito Configuration Manager, in quanto il processo di backup mette in pausa l'agente MOM, impostando fondamentalmente la modalità di manutenzione dell'agente. Per correlare l'avvio e il completamento di un sito, è necessario attivare le regole seguenti, che generano avvisi informativi quando il servizio di backup del sito viene avviato o interrotto:

  • Interruzione servizio ConfigMgr 2007: SMS_SITE_BACKUP
  • Avvio servizio ConfigMgr 2007: SMS_SITE_BACKUP

Gli avvisi seguenti vengono generati quando l'avvio del servizio di backup del sito Configuration Manager non riesce oppure in caso di arresto imprevisto:

  • Errore servizio ConfigMgr 2007: interruzione imprevista di SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: blocco all'avvio di SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: impossibile avviare SMS_SITE_BACKUP
  • Errore servizio ConfigMgr 2007: accesso di SMS_SITE_BACKUP non riuscito
  • Errore servizio ConfigMgr 2007: dipende da un altro servizio che non è stato possibile avviare o che non esiste

Se viene visualizzato un avviso indicante che un servizio è stato arrestato in modo imprevisto, verificare che tutti i servizi arrestati siano stati riavviati. È possibile che il servizio di backup del sito Configuration Manager sia stato terminato prima di riavviarli.

Gli avvisi di messaggio di stato seguenti vengono generati per indicare l'esito positivo o negativo del processo di backup:

  • Stato ConfigMgr 2007: backup del sito completato
  • Stato ConfigMgr 2007: backup del sito non riuscito
  • Stato ConfigMgr 2007: servizio di backup del sito - impossibile avviare il processo di backup fino al completamento dell'attività di backup in corso
  • Stato ConfigMgr 2007: servizio di backup del sito - il percorso di backup SQL risulta vuoto o non valido

L'avviso di errore può venire generato a causa di problemi di accesso, spazio su disco insufficiente, errori di avvio o arresto di determinati servizi o errori nel funzionamento di SQL Server.

Esaminare gli eventi

È consigliabile esaminare gli eventi regolarmente poiché essi indicano errori non gravi e offrono informazioni approfondite sulle modalità di funzionamento dell'agente Operations Manager 2007.

Per esaminare gli eventi

Per esaminare gli eventi, eseguire la procedura seguente:

Per esaminare gli eventi

  1. In Operations Console fare clic sul pulsante Monitoraggio.

  2. Espandere Microsoft System Center Configuration Manager 2007 e quindi fare clic su Eventi.

Vedere anche

Concetti

Integrazione di Configuration Manager 2007 con Operations Manager 2007
Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Attività settimanali per Configuration Manager 2007 Management Pack

Oltre alle attività di ogni giorno, è consigliabile eseguire le attività seguenti su base settimanale:

  • Analizzare i report. Per un elenco dei report inclusi in Configuration Manager 2007 Management Pack, vedere la sezione Report per Configuration Manager 2007 Management Pack della presente guida.
  • Analizzare le prestazioni, le modifiche alla configurazione, la disponibilità del server, gli eventi e gli avvisi della settimana precedente per individuare tendenze e problemi potenziali.
  • Se necessario, modificare le impostazioni di configurazione di Operations Manager 2007, ad esempio l'intervallo di heartbeat, le impostazioni degli avvisi e i parametri di pulitura database dell'agente Operations Manager 2007.
  • Analizzare la cronologia di backup dei siti di Configuration Manager 2007.
  • Analizzare la cronologia di backup del gruppo di configurazione di Operations Manager 2007 per Configuration Manager 2007.
  • Analizzare il registro e il database di SQL Server.
  • Eseguire i report di disponibilità di Configuration Manager 2007 per ottenere la disponibilità dei server Configuration Manager 2007 e dei relativi ruoli.
  • Verificare la gerarchia di Configuration Manager 2007 mediante il diagramma gerarchia siti di Configuration Manager 2007.

Vedere anche

Concetti

Attività quotidiane per Configuration Manager 2007 Management Pack
Attività mensili per Configuration Manager 2007 Management Pack

Altre risorse

Risoluzione dei problemi di Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack


Attività mensili per Configuration Manager 2007 Management Pack

Oltre alle attività eseguite su base giornaliera e settimanale, è necessario controllare i dati delle categorie seguenti su base mensile.

  • Controllare le sottoscrizioni di notifica e i relativi destinatari, verificando che per ogni sottoscrizione siano selezionati i gruppi e le classi appropriati.

Avvisi ed eventi più comuni

  • Avvisi più comuni
  • Eventi più comuni
  • Avvisi ed eventi più comuni per computer e classe
  • Avvisi ed eventi più comuni per componente di Configuration Manager 2007
  • Avvisi ed eventi più comuni per ruolo del server Configuration Manager 2007

Sviluppare un piano d'azione per ridurre questi dati.

Monitoraggio dei backlog di Configuration Manager 2007

Controllare i report delle prestazioni pure relativi alle tendenze dei backlog su vari sistemi del sito.

Tendenze dei backlog di Configuration Manager 2007

Controllare i report relativi alle prestazioni pure e alla velocità per assicurarsi che non esista una tendenza in crescita a lungo termine nel numero di backlog o un livello non accettabile di backlog per i contratti di servizio in un sistema del sito Configuration Manager 2007. Eseguire i controlli seguenti:

  • Record dei dati di individuazione
  • Inventario hardware
  • Inventario software
  • Controllo software
  • Messaggi di stato
  • Messaggi sullo stato

Prestazioni generali del sistema

Controllare nel report Prestazioni risorse di sistema server ConfigMgr 2007 i dati relativi alle prestazioni del sistema seguenti:

  • Utilizzo del disco
  • Utilizzo della memoria
  • Utilizzo del processore

Prestazioni del ruolo del server

Controllare i report relativi alle prestazioni pure e alla velocità per ognuno dei ruoli seguenti:

  • Punto di gestione dei dispositivi
  • Punto di gestione
  • Server del sito

Disponibilità di Configuration Manager 2007

Eseguire i report relativi alla disponibilità di Configuration Manager 2007 per controllare la disponibilità dei server e dei ruoli del server di Configuration Manager 2007.

Monitoraggio della gerarchia dei siti Configuration Manager 2007

Controllare l'installazione degli agenti nella gerarchia dei siti Configuration Manager e stabilire se il livello di monitoraggio è adeguato per i server distribuiti. È possibile che siano stati distribuiti nuovi server Configuration Manager nei quali non è ancora stato installato un agente MOM.

Vedere anche

Concetti

Attività quotidiane per Configuration Manager 2007 Management Pack
Attività settimanali per Configuration Manager 2007 Management Pack
Integrazione di Configuration Manager 2007 con Operations Manager 2007

Altre risorse

Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack
Risoluzione dei problemi di Configuration Manager 2007 Management Pack


Risoluzione dei problemi di Configuration Manager 2007 Management Pack

Per risolvere i problemi relativi al prodotto, è possibile eseguire le azioni seguenti.

  • Controllare che Operations Manager 2007 sia stato installato correttamente.
  • Controllare che le impostazioni di configurazione di Operations Manager 2007 siano corrette.
  • Verificare che tutti i sistemi System Center Configuration Manager 2007 siano stati configurati correttamente con la chiave del Registro di sistema Operations Management.
  • Verificare che in tutti i computer gestiti provider Configuration Manager 2007 e server del sito Configuration Manager 2007 sia stato installato l'agente Operations Manager 2007 e che tali computer siano attivati come proxy per altri computer.
  • Verificare che l'importazione del Management Pack sia stata completata senza errori.
  • Controllare che tutte le entità significative siano attivate, ad esempio le regole e i monitoraggi.
  • Controllare che i gruppi di computer contengano i computer corretti. È possibile utilizzare il nodo Gruppi della modalità Creazione e modifica della console per eseguire questo controllo.
  • Verificare che tutti gli agenti siano integri.
  • Controllare che l'intervallo di heartbeat sia impostato correttamente e che le regole vengano propagate nel computer con l'agente Microsoft Operations Manager 2007.
  • Controllare che i servizi dipendenti, inclusi Strumentazione gestione Windows (WMI), il servizio Pubblicazione sul Web, il servizio di amministrazione di Internet Information Services (IIS), il servizio di trasferimento intelligente in background, Windows Server Update Services (WSUS), Servizi di distribuzione Windows, Trivial FTP Daemon (TFTPD) e Microsoft SQL Server siano installati e funzionino correttamente nei sistemi del sito Configuration Manager 2007.
  • Controllare che tutti i contatori delle prestazioni siano stati installati correttamente.
  • Controllare che gli script dispongano di autorizzazioni sufficienti per accedere alle risorse necessarie nel caso in cui l'account azione sia diverso da LocalSystem.

In questa sezione

Problemi noti di Configuration Manager 2007 Management Pack

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack
Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack


Problemi noti di Configuration Manager 2007 Management Pack

Di seguito sono elencati i problemi noti di Configuration Manager 2007 Management Pack per Operations Manager 2007.

Configuration Manager 2007 potrebbe interferire con l'installazione di software non Microsoft che interrompe il servizio Strumentazione gestione Windows (WMI)

Monitoraggio WMI

Configuration Manager 2007 Management Pack non è in grado di rilevare un sito secondario SMS se la console di amministrazione SMS è installata sullo stesso computer

Il riavvio del sistema limita il numero di avvisi visualizzati

Script Monitor SMS Status Messages in Configuration Manager 2007

Lo script Monitor Site System Summarizer di Configuration Manager 2007 ha uno scarto rispetto all'intervallo predefinito del generatore riepilogo dello stato del sistema del sito

Il monitoraggio BITS è disattivato per impostazione predefinita

Il percorso del provider del registro applicazioni è impostato su SMS_INSTALL_DIR_PATH%\Logs per impostazione predefinita, ma tale percorso potrebbe non essere sempre valido su tutti i server del sito Configuration Manager

Le regole messaggi di stato che controllano la connettività del server Sender dipendono dal funzionamento del server Sender

Gli errori di script nella vista della topologia dei siti indicano il percorso di installazione anziché il nome del computer

È necessario un agente in tutti i server Configuration Manager per il supporto del diagramma della gerarchia dei siti

Le attività di SMS 2003 vengono visualizzate nella vista dello stato di Configuration Manager 2007

Configuration Manager potrebbe interferire con l'installazione di software non Microsoft che interrompe il servizio Strumentazione gestione Windows (WMI)

Configuration Manager 2007 Management Pack potrebbe interferire con l'installazione di software non Microsoft che accede al servizio WMI. La maggior parte degli script del Management Pack utilizza tale servizio per accedere al Registro di sistema ed è in grado di riavviarlo. Se il servizio WMI è attivato e può essere avviato, COM sarà in grado di riavviarlo.

Se il software non Microsoft si interrompe ma non disattiva WMI durante un’installazione o un aggiornamento, il riavvio automatico dello script WMI potrebbe influire sul completamento dell’installazione del software non Microsoft. Ciò potrebbe rappresentare un problema per gli aggiornamenti del servizio o del provider WMI se il programma di installazione non disattiva il servizio WMI come operazione preliminare. Ciò vale per qualsiasi client di WMI.

Monitoraggio WMI

  • Le regole seguenti si basano sugli eventi del registro eventi di sistema di Windows NT® relativi al gestore di controllo del servizio per individuare gli errori imprevisti del servizio. Non ci sono limitazioni del sistema operativo note per queste regole.
  • Errore servizio dipendente da ConfigMgr 2007: interruzione imprevista di Strumentazione gestione Windows.
  • Errore servizio dipendente da ConfigMgr 2007: blocco all'avvio di Strumentazione gestione Windows.
  • Errore servizio dipendente da ConfigMgr 2007: impossibile avviare Strumentazione gestione Windows.
  • Errore servizio dipendente da ConfigMgr 2007: accesso di Strumentazione gestione Windows non riuscito.
  • Errore servizio dipendente da ConfigMgr 2007: Strumentazione gestione Windows dipende da un altro servizio che non è stato possibile avviare o che non esiste.

Configuration Manager 2007 Management Pack non è in grado di rilevare un sito secondario se la console di amministrazione ConfigMgr 2007 è installata nello stesso computer

L'installazione di una console di amministrazione di Configuration Manager 2007 in un computer che funge anche da server del sito secondario Configuration Manager 2007 impedisce a Configuration Manager 2007 Management Pack l'identificazione del server come server del sito secondario Configuration Manager 2007.

Per risolvere il problema, quando si installa la console di amministrazione Configuration Manager 2007 in un server di sito secondario Configuration Manager 2007, è necessario modificare il valore del Registro di sistema HKLM\SOFTWARE\Microsoft\SMS\Setup\Type passando da 4 a 2.

Il riavvio del sistema limita il numero di avvisi visualizzati

In caso di riavvio del sistema, è possibile che si ricevano solo alcuni avvisi di interruzione del servizio. Non ci sono eventi o avvisi che indicano che il sistema è stato riavviato. Il modo migliore per rilevare un arresto del sistema previsto o imprevisto consiste nell'installare Microsoft Windows Servers Base Operating System Management Pack, che contiene una regola che avvisa l’utente in caso di riavvio del sistema. Per determinare se il sistema è stato riavviato è inoltre possibile controllare i registri di Configuration Manager 2007, il registro degli eventi NT di Operations Manager 2007, i registri degli eventi di Windows NT e gli eventi di Operations Manager 2007 per la comunicazione con l'agente.

Script Monitor SMS Status Messages in Configuration Manager 2007

Quando la tabella dei messaggi di stato di Configuration Manager 2007 supera i 4.294.967.296 messaggi, la numerazione dell'ID record ricomincia da zero. Lo script Monitor SMS Status Messages di Configuration Manager 2007 non dispone di un meccanismo per rilevare quando si ricomincia da zero per l'assegnazione degli ID record. Attualmente lo script parte dall’ID record dell’ultimo messaggio di stato elaborato. Se l’ID record ricomincia da zero, il Management Pack non è in grado di rilevare i nuovi messaggi di stato.

Sul lato server, si noti il valore di Next Status Message Record ID nella chiave del Registro di sistema HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER. Questo è l'ID record successivo che si trova nella tabella dei messaggi di stato di SQL. Se questo valore è inferiore al valore LastRecordID, la tabella dei messaggi di stato ha ricominciato la numerazione da zero. Lo script non elabora nuovamente i messaggi fino a quando il valore del Registro di sistema Next Status Message Record ID non risulta maggiore del valore LastRecordID nel file VarSet.

È consigliabile monitorare periodicamente la chiave del Registro di sistema HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER sul lato server per controllare l'ID record del messaggio di stato successivo. Per le piccole imprese o i siti di piccole dimensioni che si trovano a un livello basso nella gerarchia SMS, è consigliabile controllare questa chiave del Registro di sistema ogni due o tre mesi. Per le grandi imprese o i siti con parecchi siti figlio è consigliabile controllare questa chiave del Registro di sistema ogni mese. Se il valore si avvicina a 4.294.967.296, controllarlo più di frequente. Quando l'ID record ricomincia da zero, è necessario sbloccare il monitoraggio dei messaggi di stato nel computer in cui viene eseguito il server del sito.

Una soluzione per automatizzare il monitoraggio della chiave del Registro di sistema consiste nel creare uno script o una regola di individuazione per i computer che si avvicinano alla soglia.

Per individuare tutti i database del sito Configuration Manager 2007 nel gruppo di configurazione, eseguire la procedura seguente. Si noti che il ruolo Server di database del sito in effetti viene ora rilevato in ConfigMgr nel server del sito per supportare i server SQL di cluster.

Procedura

Per individuare tutti i database del sito Configuration Manager 2007 del gruppo di configurazione e sbloccare il monitoraggio dei messaggi di stato

  1. In Operations Console fare clic sul pulsante Creazione e modifica e quindi selezionare Gruppi.

  2. Nel riquadro dei risultati cercare i nomi di gruppi contenenti Gruppo di computer Server di database del sito Microsoft ConfigMgr 2007.

  3. Fare clic con il pulsante destro del mouse sul nome del gruppo di cui si desidera individuare i membri, quindi scegliere Visualizza membri del gruppo.

  4. Nel computer host del ruolo del database del sito Configuration Manager 2007, nel percorso specificato dalla variabile di ambiente TMP del contesto utente con cui vengono eseguiti gli script (la cartella temporanea di Windows nel caso del sistema locale), aprire il file di testo seguente: ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet t. La voce LastRecordID_[SMSDatabaseName] è un ID record che indica l'ultimo messaggio di stato della tabella StatusMessages SQL elaborato dallo script.

  5. Modificare il valore LastRecordID_[SMSDatabaseName] in modo che corrisponda al valore del Registro di sistema dell'ID record Next Status Message meno uno. Se il risultato è 4.294.967.296, impostare il valore su zero e salvare il file.

Lo script Monitor Site System Summarizer in Configuration Manager 2007 ha uno scarto rispetto all'intervallo predefinito del generatore riepilogo dello stato del sistema del sito

Lo script Monitor Site System Summarizer di Configuration Manager 2007 viene eseguito con uno scarto di 10 minuti rispetto al polling del generatore riepilogo dello stato del sistema del sito, per cui è impostato un intervallo di 60 minuti con decorrenza dall'ora esatta. Sebbene la console di amministrazione di Configuration Manager consenta di configurare la pianificazione del generatore riepilogo dello stato del sistema del sito, non modifica tuttavia questo intervallo di polling, ma solo l’intervallo per altre attività di manutenzione. Lo script Monitor Site System Summarizer di Configuration Manager viene eseguito ogni 60 minuti - sincronizzazione alle 00:10. Lo scarto di 10 minuti concede al generatore riepilogo dello stato del sistema del sito il tempo necessario per completare il ciclo. Se questo periodo di tempo è insufficiente, è necessario estenderlo, altrimenti lo script terminerà prima che il generatore riepilogo dello stato del sistema del sito abbia completato il ciclo. Di conseguenza, lo stato del sistema del sito visualizzato potrebbe non risultare aggiornato.

Il monitoraggio BITS è disattivato per impostazione predefinita

Poiché il servizio di trasferimento intelligente in background (BITS) viene avviato su richiesta del client di Configuration Manager 2007, la regola seguente è disattivata per impostazione predefinita in Configuration Manager Management Pack:

  • Servizio dipendente da ConfigMgr 2007 in esecuzione: Servizio trasferimento intelligente in background

Se il servizio è configurato per l'avvio automatico, è consigliabile attivare questa regola.

Le regole seguenti sono attivate per impostazione predefinita per poter controllare i problemi con il servizio BITS e poter segnalare se l'host agenti di SMS non è in grado di avviare il servizio BITS quando richiesto:

  • Errore servizio ConfigMgr 2007: interruzione imprevista di Servizio trasferimento intelligente in background.
  • Errore servizio ConfigMgr 2007: blocco all'avvio di Servizio trasferimento intelligente in background.
  • Errore servizio ConfigMgr 2007: impossibile avviare Servizio trasferimento intelligente in background.
  • Errore servizio ConfigMgr 2007: accesso di Servizio trasferimento intelligente in background non riuscito.
  • Errore servizio ConfigMgr 2007: Servizio trasferimento intelligente in background dipende da un altro servizio che non è stato possibile avviare o che non esiste.

Il percorso del provider del registro applicazioni è impostato su SMS_INSTALL_DIR_PATH%\Logs per impostazione predefinita, ma tale percorso potrebbe non essere sempre valido su tutti i server del sito SMS

Le regole dei componenti seguenti utilizzano i registri applicazioni:

  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione standard).
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite la connessione RAS.
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione avanzata).
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile elaborare un pacchetto.
  • Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile inserire un pacchetto SMS perché il contenuto di tipo SDM non è presente nella tabella CI_Contents.
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di aggiornamento software dal database di sito SMS.
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di aggiornamento software.
  • Componente ConfigMgr 2007: provider di criteri - impossibile ottenere i nuovi criteri di conformità dal database di sito SMS.
  • Componente ConfigMgr 2007: provider di criteri - impossibile creare nuovi criteri di conformità.
  • Componente ConfigMgr 2007: provider di criteri - impossibile inviare notifica di una modifica dei criteri al componente di gestione della gerarchia

Per garantire il funzionamento di queste regole, è necessario creare la variabile di ambiente %SMS_INSTALL_DIR_PATH% nel server del sito con il percorso di installazione specificato per l'installazione del sito. Il percorso della variabile di ambiente non deve terminare con una barra rovesciata. È inoltre necessario che ogni server Configuration Manager 2007 con un server Sender sia un computer gestito.

Tutte le regole tranne Componente ConfigMgr 2007: servizio di gestione della distribuzione - impossibile elaborare un pacchetto sono attivate per impostazione predefinita.

Le regole messaggi di stato che controllano la connettività del server Sender dipendono dal funzionamento del server Sender

Se il server Sender non è in grado di connettersi al sito padre, i messaggi di stato non vengono trasmessi attraverso la gerarchia di Configuration Manager e il Management Pack non genera un avviso relativo a tali messaggi di stato. Ciò è particolarmente importante nel caso di siti secondari per cui non è in esecuzione lo script ConfigMgr 2007 Monitor SMS Status Messages. Le regole messaggi di stato seguenti che controllano la connettività del server Sender dipendono dal funzionamento del Sender e sono disattivate per impostazione predefinita:

  • Stato ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione standard).
  • Stato ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite la connessione RAS.
  • Stato ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione avanzata).
Nota
Tutte queste regole sono disattivate per impostazione predefinita. Affinché queste regole possano funzionare, è necessario che ogni server di database del sito SMS o almeno il sito centrale sia un computer gestito.

È stato fornito un metodo di monitoraggio parallelo basato sul registro del server Sender di Configuration Manager 2007. Queste regole sono attivate per impostazione predefinita. Se queste regole vengono disattivate, è consigliabile considerare l'attivazione delle regole messaggi di stato complementari sopra indicate. Non attivare entrambi i set di regole, perché verranno generati avvisi duplicati. Non esiste un consolidamento di questi eventi o di queste regole avvisi in grado di fare riferimento sia alla regola componenti che alla regola messaggi di stato attiva.

  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione standard).
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite la connessione RAS.
  • Componente ConfigMgr 2007: il server Sender non è in grado di connettersi al sito remoto tramite LAN (protezione avanzata).

Per garantire il funzionamento di queste regole, è necessario creare la variabile di ambiente %SMS_INSTALL_DIR_PATH% nel server del sito con il percorso di installazione specificato per l'installazione del sito. Il percorso della variabile di ambiente non deve terminare con una barra rovesciata. È inoltre necessario che ogni server Configuration Manager con un server Sender sia un computer gestito. Per ulteriori informazioni, vedere Il percorso del provider del registro applicazioni è impostato su SMS_INSTALL_DIR_PATH%\Logs per impostazione predefinita, ma tale percorso potrebbe non essere sempre valido su tutti i server del sito Configuration Manager.

Gli errori di script nella vista di individuazione della gerarchia dei siti indicano il percorso di installazione anziché il nome del computer

Quando si visualizzano gli errori dello script di individuazione della gerarchia dei siti ConfigMgr 2007 e di regole create in modo nativo, la classe di installazione del computer che genera l'errore viene indicata come Origine. Il nome del computer che genera l'errore viene indicato come parte del campo Descrizione avviso o Percorso relativo all'errore di script.

È necessario un agente in tutti i server Configuration Manager per il supporto del diagramma della gerarchia dei siti

Per garantire il funzionamento del Diagramma gerarchia siti, è necessario installare l'agente a livello locale in tutti i server Configuration Manager di un sito, inclusi i server SQL remoti che fungono da host per il database del sito. Questo vale per tutti i siti monitorati, inclusi i siti centrali, primari e secondari.

Le attività di SMS 2003 vengono visualizzate nella vista dello stato di Configuration Manager 2007

Quando sono installati sia System Management Server (SMS) 2003 Management Pack che Configuration Manager 2007 Management Pack, le attività di SMS 2003 sono visibili nella vista dello stato di Configuration Manager 2007 in quanto si riferiscono alla classe Windows Computer anziché alla classe SMS Server.

Vedere anche

Concetti

Configurazioni supportate per Configuration Manager 2007 Management Pack

Altre risorse

Risoluzione dei problemi di Configuration Manager 2007 Management Pack
Panoramica di Configuration Manager 2007 Management Pack
Informazioni di riferimento per Configuration Manager 2007 Management Pack


Informazioni di riferimento per Configuration Manager 2007 Management Pack

Il materiale di riferimento seguente include informazioni su Operations Manager 2007 e Configuration Manager 2007.

In questa sezione

Risorse aggiuntive per Configuration Manager 2007 Management Pack

Siti e componenti di Configuration Manager 2007 Management Pack

Gruppi di computer per Configuration Manager 2007 Management Pack

Classi di installazione per Configuration Manager 2007 Management Pack

Script per Configuration Manager 2007 Management Pack

Viste per Configuration Manager 2007 Management Pack

Diagrammi per Configuration Manager 2007 Management Pack

Report per Configuration Manager 2007 Management Pack

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack per Configuration Manager 2007

Altre risorse

Panoramica di Configuration Manager 2007 Management Pack
Distribuzione di Configuration Manager 2007 Management Pack
Esecuzione di attività operative per Configuration Manager 2007 Management Pack


Risorse aggiuntive per Configuration Manager 2007 Management Pack

Sono disponibili le risorse seguenti relative a System Center Configuration Manager 2007 Management Pack.

Microsoft Operations Manager 2007

Per accedere alla documentazione principale di Operations Manager 2007 disponibile su Internet e per ottenere le informazioni più recenti su System Center Operations Manager 2007, visitare la pagina Web relativa a Operations Manager 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=83259.

System Center Configuration Manager 2007

Tutte le informazioni necessarie per la distribuzione e l'utilizzo di Configuration Manager 2007 sono disponibili nella documentazione principale del prodotto, nella Guida in linea della console di amministrazione di Configuration Manager 2007, nel glossario di Configuration Manager 2007 e nella documentazione in linea di Configuration Manager 2007. La raccolta di documentazione tecnica su Configuration Manager 2007 e la Guida in linea della console di amministrazione di Configuration Manager 2007 sono accessibili dalla console di amministrazione di Configuration Manager 2007.

Raccolta di documentazione tecnica su Configuration Manager 2007

  • La raccolta di documentazione tecnica su Configuration Manager 2007 offre informazioni necessarie per distribuire e utilizzare Configuration Manager 2007. Viene installata con Configuration Manager 2007.

Risorse sul Web per Configuration Manager 2007

  • Per informazioni aggiornate su Configuration Manager 2007, vedere la pagina Web della raccolta di documentazione tecnica su Configuration Manager (http://go.microsoft.com/fwlink/?LinkID=98803).
  • Per ulteriori informazioni, vedere l'elenco delle altre opzioni di supporto nella sezione del sito Web Configuration Manager relativa al supporto tecnico per Configuration Manager (http://go.microsoft.com/fwlink/?LinkId=98800).
  • Per trovare rapidamente risposte accurate a domande relative a SMS eseguendo ricerche nella Microsoft Knowledge Base e in altre risorse tecniche, visitare il sito Web Guida in linea e supporto tecnico Microsoft. È possibile eseguire ricerche nella Knowledge Base per trovare articoli relativi a problemi specifici mediante il numero "Qxxxxxx" oppure il numero "xxxxxxx" assegnato al problema.

Commenti e suggerimenti degli utenti

  • È possibile inviare commenti e suggerimenti che consentano al team della documentazione di Configuration Manager 2007 di offrire le informazioni sul prodotto di maggiore interesse per gli utenti. Inviare commenti e suggerimenti sulla documentazione a Configuration Manager 2007.

Vedere anche

Concetti

Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Siti e componenti di Configuration Manager 2007 Management Pack

I componenti di System Center Configuration Manager includono il server del sito centrale Configuration Manager, il database di sito Configuration Manager e la console di amministrazione di Configuration Manager. In genere il server del sito centrale Configuration Manager, il database di sito Configuration Manager e la console di amministrazione di Configuration Manager risiedono nello stesso server e ogni ruolo del sistema del sito risiede in un server dedicato. Insieme agli eventuali ruoli del sistema del sito, il database e il server del sito centrale costituiscono un singolo sito Configuration Manager, che può includere più ruoli del sistema del sito duplicati. È possibile creare più livelli per i siti Configuration Manager 2007. Un sito Configuration Manager può non includere alcuni ruoli del server del sito, ad esempio un punto di localizzazione del server.

Configuration Manager 2007 Management Pack è stato progettato per monitorare la gerarchia dei siti Configuration Manager e i server in essa contenuti. Questo Management Pack non è stato progettato per monitorare le funzionalità di Configuration Manager nei client Configuration Manager. È tuttavia possibile utilizzare Operations Manager 2007 per monitorare altre applicazioni presenti in un computer client Configuration Manager.

Per ulteriori informazioni sui componenti di Configuration Manager 2007, vedere la documentazione in linea di Configuration Manager. Per collegamenti alla documentazione di Configuration Manager, vedere la sezione Risorse aggiuntive per Configuration Manager 2007 Management Pack in questa guida.

I ruoli principali del server sono i seguenti:

  • Punto di distribuzione
  • Punto di gestione
  • Punto di localizzazione del server
  • Punto di reporting
  • Punto di aggiornamento del software
  • Server del sito
  • Database di sito
  • Provider Configuration Manager
  • Punto di gestione dei dispositivi mobili
  • Console di amministrazione di Configuration Manager
  • Punto dello stato di fallback
  • Punto di servizio PXE
  • Punto di convalida dell'integrità di sistema
  • Punto di localizzazione del server
  • Punto di migrazione dello stato

Punto di distribuzione

Nel punto di distribuzione sono memorizzati i file di origine del pacchetto di Configuration Manager utilizzati dai client Configuration Manager durante l'installazione dei programmi software distribuiti da Configuration Manager. Quando un amministratore di Configuration Manager annuncia un programma, le informazioni dell'annuncio e del programma risultano disponibili ai client attraverso un punto di gestione.

Quando Configuration Manager è configurato, al server del sito viene automaticamente assegnato il ruolo punto di distribuzione. L'amministratore di Configuration Manager può attivare l'utilizzo del servizio BITS (Servizio trasferimento intelligente in background) da parte del punto di distribuzione per consentire il download del file del pacchetto incrementale nei client.

I client utilizzano il servizio BITS (Servizio trasferimento intelligente in background) per individuare automaticamente la capacità di connessione di rete dei client e regolare in modo efficace le velocità di trasferimento. Questa funzionalità è supportata solo nei client che eseguono i sistemi operativi Microsoft Windows XP Professional, Microsoft Windows Server™ 2003 e Windows Vista.

Punto di gestione

Il punto di gestione è il punto principale di contatto tra i client Configuration Manager e il server del sito Configuration Manager. Un sito Configuration Manager ha un solo punto di gestione predefinito, ma è possibile configurare più punti di gestione con il servizio di bilanciamento del carico di rete di Windows. I punti di gestione hanno le caratteristiche seguenti:

  • Offrono dettagli della configurazione specifici per il client dopo l'installazione dello stesso.
  • Fungono da fonte di annunci per i computer client.
  • Individuano i punti di distribuzione per i client.
  • Ricevono le informazioni relative a stato, inventari e controllo software dai client e le inoltrano al server del sito Configuration Manager.

Punto di localizzazione del server

Il punto di localizzazione del server consente di individuare i punti di gestione per i client Configuration Manager. Questo punto viene utilizzato principalmente durante l'installazione dei client. Il punto di localizzazione del server:

  • Individua un punto di gestione per i client se il client è configurato per l'assegnazione automatica del sito Configuration Manager.
  • Offre ai client la posizione del punto di gestione durante l'installazione del client avviata dallo script di accesso e durante un'installazione senza credenziali sufficienti.

Punto di reporting

Un punto di reporting è un server che esegue il servizio IIS (Internet Information Services) e contiene il codice per il visualizzatore di report e report supplementari. Un punto di reporting comunica solo con il proprio server di database di sito Configuration Manager.

Punto di aggiornamento del software

Il punto di aggiornamento del software in Configuration Manager 2007 è un componente necessario per gli aggiornamenti software e viene installato come ruolo di sistema del sito nella console di Configuration Manager. Il ruolo di sistema del sito punto di aggiornamento del software deve essere creato in un server di sistema del sito con Windows Server Update Services (WSUS) 3.0 e che interagisce con i componenti WSUS per configurare le impostazioni di aggiornamento, per richiedere la sincronizzazione al server di aggiornamento padre e per sincronizzare gli aggiornamenti dal database WSUS al database del server del sito.

Per attivare il monitoraggio del punto di aggiornamento del software e di Windows Server Update Services, eseguire la procedura seguente.

Per attivare il monitoraggio del punto di distribuzione del software e di Windows Server Update Services

  1. In Operations Console fare clic su Creazione e modifica.

  2. Nel riquadro di spostamento passare a Creazione e modifica > Oggetti Management Pack e quindi fare clic su Regole.

  3. Nel riquadro delle regole cercare la regola da attivare. Se la barra Cerca non è disponibile al di sopra dell'elenco delle regole, passare a Visualizza e quindi fare clic su Trova.

  4. Fare clic con il pulsante destro del mouse sul nome della regola da attivare, passare a Sostituzioni > Sostituisci regola, quindi fare clic sull'insieme di oggetti da monitorare tramite la regola.

  5. Impostare le proprietà Enabled su True e modificare eventualmente le soglie in base all'ambiente in uso. Fare clic su OK.

Server del sito

Ruolo di sistema del sito Configuration Manager assegnato al server in cui è stato eseguito correttamente il programma di installazione di Configuration Manager. Quando un sito Configuration Manager viene installato in un computer, a quest'ultimo viene assegnato automaticamente il ruolo di server del sito. Ogni sito Configuration Manager ha un solo server del sito.

Database di sito

Ruolo di sistema del sito Configuration Manager assegnato al computer che ospita il database di sito Configuration Manager (un database SQL Server).

Provider Configuration Manager

Il provider Configuration Manager elabora le richieste di dati del database di sito Configuration Manager. Il ruolo provider Configuration Manager viene installato nello stesso computer del server del sito Configuration Manager o del database di sito Configuration Manager. È consigliabile installare il provider Configuration Manager e il database di sito Configuration Manager nello stesso server del sito. Il provider Configuration Manager garantisce l'accesso ai dati per la console di amministrazione di Configuration Manager installata nel sito.

Punto di gestione dei dispositivi mobili

Il punto di gestione dei dispositivi è un ruolo del sito che dipende dal ruolo punto di gestione di Configuration Manager 2007. Il punto di gestione dei dispositivi è il punto di comunicazione per i client dei dispositivi Windows Mobile Configuration Manager 2007 e deve trovarsi nello stesso computer del punto di gestione di Configuration Manager 2007.

Console di amministrazione di Configuration Manager

La console di amministrazione di Configuration Manager 2007 è l'interfaccia utente grafica utilizzata per amministrare Configuration Manager. Questa interfaccia utilizza uno snap-in MMC (Microsoft Management Console) incluso nel software di Configuration Manager. Per impostazione predefinita, la console viene installata quando si installa un server del sito primario. Può inoltre essere installata in altri server o workstation.

Punto dello stato di fallback

Sistema del sito Configuration Manager che raccoglie i messaggi sullo stato attuale dai client che non vengono installati correttamente, che non possono essere assegnati a un sito Configuration Manager 2007 o che non riescono a trovare o a comunicare con il punto di gestione assegnato. I messaggi sullo stato attuale vengono inoltre inviati al punto dello stato di fallback quando il client viene installato e assegnato correttamente.

Punto di servizio PXE

Configuration Manager 2007 utilizza il ruolo del sito punto di servizio PXE per iniziare il processo di distribuzione del sistema operativo. Il punto di servizio PXE deve essere configurato per rispondere alle richieste di avvio PXE eseguite dai client Configuration Manager 2007 in rete e quindi interagire con l'infrastruttura di Configuration Manager 2007 per determinare le operazioni di distribuzione appropriate da eseguire.

Punto di convalida dell'integrità di sistema

Il punto di convalida dell'integrità di sistema è il ruolo del sistema del sito Configuration Manager 2007 che viene eseguito in Windows Server 2008 con il ruolo Server dei criteri di rete. Quando si utilizza Protezione accesso alla rete in Configuration Manager 2007, il punto di convalida dell'integrità di sistema è necessario per convalidare lo stato di integrità dei client Configuration Manager in cui Protezione accesso alla rete è attivato per generare uno stato di integrità del client conforme o non conforme oppure una condizione di errore che ha impedito la determinazione dello stato di integrità.

Punto di localizzazione del server

I punti di localizzazione del server vengono utilizzati in una gerarchia di Configuration Manager 2007 per completare l'assegnazione del sito client nella Intranet e agevolare l'individuazione dei punti di gestione da parte dei client quando tali informazioni non sono disponibili tramite Servizio di dominio Active Directory. I client della Intranet utilizzano Servizio di dominio Active Directory come metodo preferito per completare l'assegnazione dei sito e individuare i punti di gestione. I client devono tuttavia utilizzare un punto di localizzazione del server se lo schema di Active Directory non è esteso per Configuration Manager 2007 o se il sito non è pubblicato in Servizio di dominio Active Directory oppure se i client non appartengono alla stessa foresta di Active Directory del server del sito.

Punto di migrazione dello stato

Il punto di migrazione dello stato viene utilizzato dalla distribuzione del sistema operativo di Configuration Manager 2007 quando si esegue la migrazione dello stato e delle impostazioni utente da un computer a un altro come parte della distribuzione dell'immagine del sistema operativo. Il punto di migrazione dello stato richiede l'installazione di Internet Information Services.

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Gruppi di computer per Configuration Manager 2007 Management Pack

Configuration Manager 2007 Management Pack offre i gruppi di computer seguenti:

  • Console di amministrazione Microsoft ConfigMgr 2007: sistemi del sito, server membri o workstation ConfigMgr 2007 in cui è installata la console di amministrazione.
  • Client avanzati Microsoft ConfigMgr 2007: client avanzati ConfigMgr 2007 installati su tutti i sistemi.
  • Server del punto di distribuzione secondario Microsoft ConfigMgr 2007: client ConfigMgr 2007 che fungono da server del punto di distribuzione secondario.
  • Server del sito centrale Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito centrale.
  • Client Microsoft ConfigMgr 2007: computer in cui è installato il client di ConfigMgr 2007.
  • Server del componente Microsoft ConfigMgr 2007 basati su IIS: server del sito o sistemi del sito ConfigMgr 2007 che eseguono servizi IIS.
  • Server del componente Microsoft ConfigMgr 2007 basati su SMS Executive: server del sito o sistemi del sito ConfigMgr 2007 che eseguono il servizio SMS Executive.
  • Server del punto di gestione dei dispositivi Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di gestione dei dispositivi.
  • Server del punto di distribuzione Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server dei punti di distribuzione.
  • Server del punto dello stato di fallback Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 in cui è installato il punto dello stato di fallback ConfigMgr.
  • Server del punto di gestione Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di gestione.
  • Server del sito primario Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che fungono da server del sito primario.
  • Provider Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da provider ConfigMgr.
  • Server del punto di servizio PXE Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server Servizi di distribuzione Windows in cui è installato il punto di servizio PXE di ConfigMgr.
  • Server del punto di reporting Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di reporting.
  • Server del sito secondario Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito secondario.
  • Server del punto di localizzazione del server Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di localizzazione dei server.
  • Server Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007.
  • Server database del sito Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server di database del sito.
  • Server del sito Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito primario o secondario.
  • Server del punto di aggiornamento del software Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server Windows Server Update Services (WSUS) in cui è installato il punto di aggiornamento del software ConfigMgr.
  • Server del punto di distribuzione standard Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server dei punti di distribuzione standard.
  • Server del punto di migrazione dello stato Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 in cui è installato il punto di migrazione dello stato ConfigMgr.
  • Server di convalida dell'integrità di sistema Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server IAS (Internet Authentication Server) in cui è installato il servizio di convalida dell'integrità di sistema ConfigMgr.

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Classi di installazione per Configuration Manager 2007 Management Pack

In questa sezione sono elencate le classi di installazione di System Center Configuration Manager 2007 Management Pack utilizzate per regole, monitoraggi e così via. Aprire Creazione e modifica in Operations Manager 2007 Operations Console e impostare l'ambito sulle specifiche classi di interesse.

  • Console di amministrazione Microsoft ConfigMgr 2007: sistemi del sito, server membri o workstation ConfigMgr 2007 in cui è installata la console di amministrazione.
  • Client avanzati Microsoft ConfigMgr 2007: client avanzati ConfigMgr 2007 installati su tutti i sistemi.
  • Server del punto di distribuzione secondario Microsoft ConfigMgr 2007: client ConfigMgr 2007 che fungono da server del punto di distribuzione secondario.
  • Server del sito centrale Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito centrale.
  • Client Microsoft ConfigMgr 2007: computer in cui è installato il client di ConfigMgr 2007.
  • Server del componente Microsoft ConfigMgr 2007 basati su IIS: server del sito o sistemi del sito ConfigMgr 2007 che eseguono servizi IIS.
  • Server del componente Microsoft ConfigMgr 2007 basati su SMS Executive: server del sito o sistemi del sito ConfigMgr 2007 che eseguono il servizio SMS Executive.
  • Server del punto di gestione dei dispositivi Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di gestione dei dispositivi.
  • Server del punto di distribuzione Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server dei punti di distribuzione.
  • Server del punto dello stato di fallback Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 in cui è installato il punto dello stato di fallback ConfigMgr.
  • Server del punto di gestione Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di gestione.
  • Server del sito primario Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che fungono da server del sito primario.
  • Provider Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da provider ConfigMgr.
  • Server del punto di servizio PXE Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server di Servizi di distribuzione Windows in cui è installato il punto di servizio PXE di ConfigMgr.
  • Server del punto di reporting Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di reporting.
  • Server del sito secondario Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito secondario.
  • Server del punto di localizzazione del server Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da punti di localizzazione dei server.
  • Server Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007.
  • Server database del sito Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server di database del sito.
  • Server del sito Microsoft ConfigMgr 2007: server del sito ConfigMgr 2007 che fungono da server del sito primario o secondario.
  • Server del punto di aggiornamento del software Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server Windows Server Update Services (WSUS) in cui è installato il punto di aggiornamento del software ConfigMgr.
  • Server del punto di distribuzione standard Microsoft ConfigMgr 2007: server del sito o sistemi del sito ConfigMgr 2007 che fungono da server dei punti di distribuzione standard.
  • Server del punto di migrazione dello stato Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 in cui è installato il punto di migrazione dello stato ConfigMgr.
  • Server di convalida dell'integrità di sistema Microsoft ConfigMgr 2007: sistemi del sito ConfigMgr 2007 che sono server IAS (Internet Authentication Server) in cui è installato il servizio di convalida dell'integrità di sistema ConfigMgr.

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Script per Configuration Manager 2007 Management Pack

Configuration Manager 2007 Management Pack include script di Operations Manager 2007 eseguiti automaticamente nell'agente e script che devono essere eseguiti da un amministratore. In questa sezione sono disponibili informazioni aggiuntive su alcuni di questi script.

Gli script seguenti vengono eseguiti automaticamente dall'agente Operations Manager 2007:

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Component Health
  • ConfigMgr 2007 Monitor NLB Management Point Health
  • ConfigMgr 2007 Monitor Server Health
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Inbox
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks
  • ConfigMgr 2007 Service Discovery - Client
  • ConfigMgr 2007 Service Discovery - Server
  • Individuazione gerarchia dei siti ConfigMgr 2007

ConfigMgr 2007 Monitor SMS Status Messages

Numerosi problemi di Configuration Manager 2007 vengono rilevati e segnalati internamente tramite il sistema di stato di SMS. I messaggi di stato vengono generati dai componenti di Configuration Manager 2007 riguardo a condizioni di interesse per un amministratore di Configuration Manager 2007.

I messaggi di stato vengono trasmessi nel database di un sito Configuration Manager 2007 e, a un livello superiore nella gerarchia di siti, nel database del sito padre. È possibile monitorare il sistema di stato di Configuration Manager 2007 per ogni singolo sito, semplicemente eseguendo query sulla tabella dei messaggi di stato di Configuration Manager 2007 del database di un sito specifico.

Per il monitoraggio è stato scelto un insieme di messaggi di stato che riflettono gli eventi più critici per gli amministratori di Configuration Manager 2007. Quando nel database viene individuato uno di questi messaggi, viene generato un avviso.

Questo script esegue le operazioni seguenti:

  • Verifica se è in esecuzione in modalità gestita senza agente. In tal caso, lo script viene chiuso senza eseguire ulteriori azioni.
  • Inizializza le variabili globali.
  • Apre e legge l'elemento RecordID dell'ultimo messaggio di stato elaborato per ogni database di sito Configuration Manager monitorato dal file ConfigMgr 2007 Monitor SMS Status Messages.VarSet.
  • Elabora i messaggi di stato individuati in ogni database di sito Configuration Manager 2007 nel computer locale.
  • Scrive l'elemento RecordID dell'ultimo messaggio di stato elaborato, per il database di sito Configuration Manager 2007 monitorato, nel file ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet e chiude il file.

Tramite lo script ConfigMgr 2007 Monitor SMS Status Messages vengono generati eventi il cui ID corrisponde a quello del messaggio di stato di SMS in cui vengono segnalati. Nella tabella seguente è descritto il formato dell'evento generato.

Formato degli eventi generati dallo script ConfigMgr 2007 Monitor SMS Status Messages

Parametro | Descrizione
EventType | Operazione riuscita, Errore, Avviso o Informazioni, in base alla gravità del messaggio di stato di SMS.
EventNumber | ID del messaggio di stato di SMS
Category | Codice del sito ConfigMgr
LoggingDomain | Dominio delle risorse del computer
LoggingComputer | Nome NetBIOS del computer
Parameter1 | Nome NetBIOS del computer
Parameter2 | Nome del modulo di Configuration Manager, ad esempio Server Configuration Manager
Parameter3 | Nome del componente di Configuration Manager
Parameter4 | ID del messaggio SMS
Parameter5 | Codice di errore Win32
Parameter6 | Codice del sito padre o del sito principale
Parameter7 | Elemento RecordID del messaggio di stato nella tabella dei messaggi di stato di SMS
Description | "Nuovo messaggio di stato SMS monitorato nel computer <NetBIOS Name> del componente <Component Name> con ID messaggio <Message ID> trovato nel database del sito <Site Code>."

Tramite lo script ConfigMgr 2007 Monitor SMS Status Messages vengono inoltre segnalati gli errori di script, contrassegnati dall'ID del messaggio di stato 1102:

EventType= Avviso

EventNumber= 1102

Description = Errore di runtime dello script ConfigMgr 2007 Monitor SMS Status Messages in esecuzione in virtù della regola <ScriptProcessingRuleName>. Il messaggio di errore conterrà il testo "Impossibile <ErrorDescription>".

Tutti i messaggi di stato di Configuration Manager 2007 che monitorano regole eventi iniziano con: “Stato ConfigMgr 2007:” e sono associati alla classe Server database del sito Microsoft ConfigMgr 2007.

  • Stato ConfigMgr 2007: monitoraggio dei messaggi

Stato ConfigMgr 2007: monitoraggio dei messaggi avvia lo script ogni 30 minuti partendo dalle 00:02. Le informazioni di riepilogo sono disponibili nella pagina delle proprietà Knowledge della regola.

Nota
Stato ConfigMgr 2007: monitoraggio dei messaggi richiede molto tempo per essere eseguito se nelle tabelle monitorate sono presenti molti dati cronologici. Per questa query è consigliabile eliminare i messaggi di stato meno recenti per assicurarsi che non venga eseguita per troppo tempo.

  • Stato ConfigMgr 2007: errore script

Stato ConfigMgr 2007: errore script esegue il monitoraggio degli eventi di errore di script che potrebbero essere generati e invia avvisi relativi a tali eventi. Esiste un solo evento di errore di script, il numero 1102, che segnala tutti gli errori di script. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

  • Stato ConfigMgr 2007: <status message name>

Stato ConfigMgr 2007: <nome messaggio stato> esegue il monitoraggio di eventi di messaggio di stato specifici e invia avvisi relativi a tali eventi. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

Tutti gli avvisi includono una descrizione dell'evento con il formato seguente, dove $Description$ indica la descrizione dell'evento:

$Logging Computer$ - "Nome regola". $Description$

Nel file ConfigMgr 2007 Monitor SMS Status Messages.VarSet viene memorizzato in modo permanente l'elemento RecordID dell'ultimo messaggio di stato elaborato per un sito. Tale file VarSet si trova nella cartella specificata dalla variabile di ambiente TMP. Si tratta di un file delimitato da tabulazione con il formato seguente:

Copia codice
LastRecordID_DBNameRecordID#

LastRecordID_SMS_FLA, con RecordID di 477860 indicherebbe, ad esempio, che l'ultimo elemento RecordID elaborato dal database del sito denominato SMS_FLA è stato il numero 477860.

Quando si aggiorna Management Pack da una versione precedente, nel file VarSet dello script ConfigMgr 2007 Monitor SMS Status Messages possono essere presenti i valori seguenti:

Copia codice
LastRecordID476743
LastRecordID_SMS_FLA477860

La prima riga, che non contiene un nome di database, indica la versione originale del monitoraggio dei messaggi di stato che non supporta il monitoraggio di più database. La seconda riga, che contiene un nome di database, ovvero SMS_FLA, indica che la versione corrente del monitoraggio dei messaggi di stato supporta il monitoraggio di più database.

Non verranno intraprese azioni per utilizzare la prima riga di dati in quanto, nel caso dei database di sito multipli, è difficile determinare a quale database corrisponde. La prima riga di dati non viene rimossa dal file VarSet, in quanto può essere utile per valutare le nuove modifiche e verificare che il monitoraggio dei messaggi di stato inizi con il valore di RecordID corretto dopo l'aggiornamento. In Configuration Manager 2007 tutti gli script che accedono al database di sito vengono eseguiti dal server del sito per supportare i cluster SQL. Si tratta di una modifica del comportamento rispetto a SMS 2003, in cui gli script vengono sempre eseguiti localmente rispetto al server SQL. Le istanze dei server di database del sito di Configuration Manager 2007 corrisponderanno pertanto a quelle rilevate di dei server del sito di Microsoft Configuration Manager.

ConfigMgr 2007 Monitor Site System Summarizer

Generatore riepilogo dello stato del sistema del sito

Il generatore riepilogo dello stato del sistema del sito è un thread componente del servizio SMS Executive che gestisce lo stato in tutti i sistemi del sito Configuration Manager 2007 definiti. Per impostazione predefinita, il polling dello stato corrente viene eseguito una volta all'ora, ogni ora esatta. Questo intervallo di polling è definito nel file di controllo del sito Configuration Manager 2007. È consigliabile non modificare l'intervallo di polling. Lo stato viene memorizzato in una tabella nel database di sito Configuration Manager 2007.

Stato DownSince del sistema del sito

Quando il generatore riepilogo dello stato del sistema del sito non è in grado di contattare un sistema del sito durante uno degli intervalli di polling, il sistema del sito viene considerato inattivo. Questa situazione può verificarsi a causa di uno dei fattori seguenti:

  • Il sistema del sito non è acceso, non è connesso alla rete o non funziona correttamente.
  • Il generatore riepilogo dello stato del sistema del sito ConfigMgr 2007 non dispone di una connessione in quanto non vi sono connessioni disponibili.
  • Il generatore riepilogo dello stato del sistema del sito ConfigMgr 2007 non dispone di autorizzazioni di accesso sufficienti per la connessione al sistema del sito.
  • Il generatore riepilogo dello stato del sistema del sito ConfigMgr 2007 non è in grado di connettersi al sistema del sito a causa di problemi di rete.
  • Il sistema del sito è stato messo definitivamente fuori servizio.

Il valore DownSince è una colonna della tabella di database Summarizer_SiteSystem del sito.

Sono presenti i vincoli seguenti:

  • L'intervallo di polling del generatore riepilogo dello stato del sistema del sito è di un'ora. Questo intervallo di tempo è sufficiente per l'esecuzione del polling di tutti i sistemi del sito da parte del generatore riepilogo dello stato del sistema del sito. Per garantire un livello adeguato di prestazioni, non è possibile modificare questo intervallo. L'intervallo di timeout del generatore riepilogo è controllato dalla proprietà Startup Schedule del file di controllo del sito e non dalla proprietà Wakeup Interval. Questo significa che la modifica del valore predefinito della proprietà Wakeup Interval, pari a 60, non ha alcun effetto. Lo stesso vale per la proprietà Startup Schedule, la cui modifica non ha alcun effetto. Per impostazione predefinita, questa proprietà è impostata per l'esecuzione ogni 60 minuti e il generatore riepilogo dello stato del sistema del sito esegue il polling dei sistemi del sito una volta all'ora, indipendentemente dall'impostazione di Startup Schedule.
  • Viene generato un avviso solo se si verificano due eventi del generatore riepilogo dello stato del sistema del sito ConfigMgr 2007: il sistema del sito potrebbe essere inattivo in un periodo di due ore. In questo modo, è possibile tenere conto di situazioni di interruzione temporanea della connettività.
  • Molti casi di mancata disponibilità di Configuration Manager 2007 non vengono monitorati dal generatore riepilogo dello stato del sistema del sito. Configuration Manager viene ad esempio considerato disponibile dal generatore riepilogo dello stato del sistema del sito anche se i relativi servizi SMS non sono in esecuzione o se il database di sito Configuration Manager 2007 non è disponibile, ad esempio quando il servizio SQL Server è interrotto.
  • Tramite il generatore riepilogo dello stato del sistema del sito, lo stato "DownSince" corrente di ogni oggetto del sito e ruolo del sistema del sito ospitato in un computer viene scritto nel database, nella tabella del generatore riepilogo dello stato del sistema del sito.

Lo script Monitor Site System Summarizer esamina ogni ruolo del sistema del sito presente in tale tabella. Se un sistema del sito è contrassegnato come inattivo, viene generato un evento, in seguito al quale viene generato un avviso. Più ruoli possono generare più avvisi.

Ogni ruolo del server di Configuration Manager 2007, fatta eccezione per i punti di distribuzione di Configuration Manager 2007, crea per impostazione predefinita due ruoli del server di Configuration Manager 2007: uno per il ruolo specifico e l'altro per il server del componente Configuration Manager 2007. Nel caso, ad esempio, di un sistema del sito che ospita sia un punto di localizzazione del server che un punto di reporting, se il server rimane non in linea per più di due ore, ovvero due intervalli di polling del generatore riepilogo dello stato del sistema del sito, entrambi questi ruoli e i relativi ruoli del server del componente Configuration Manager vengono contrassegnati come inattivi.

Per il periodo di due ore vengono tuttavia generati solo tre avvisi per ogni intervallo di polling, uno per ogni ruolo del server e uno per il server del componente fisico che ospita i due ruoli del server.

  • Per impostazione predefinita, l'intervallo pianificato è di 60 minuti con uno scarto di 10 minuti dall'ora esatta, in modo che lo script ConfigMgr 2007 Monitor Site System Summarizer venga eseguito 10 minuti dopo l'inizio dell'intervallo di polling del generatore riepilogo dello stato del sistema del sito di un'ora. Se il generatore riepilogo impiega più di 10 minuti per completare il ciclo, è necessario aumentare lo scarto del provider di eventi temporizzati in modo appropriato. In caso contrario, i messaggi di stato del sistema del sito più recenti andranno persi.

Script ConfigMgr 2007 Monitor SMS Executive Crash Dumps

Questo script esegue le operazioni seguenti:

  • Determina se il computer di destinazione è in esecuzione in modalità senza agente. In tal caso, lo script viene chiuso senza eseguire ulteriori azioni. Poiché lo script prevede l'utilizzo di un file VarSet locale per memorizzare in modo permanente le variabili, è necessario che l'agente Operations Manager 2007 sia installato in tutti i computer di destinazione che eseguono il servizio SMS Executive.
  • Apre e legge il contenuto del file ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet locale nel percorso specificato dalla variabile di ambiente TMP in una raccolta. Se il file non esiste, non viene generato alcun evento di errore di script. Se il file esiste ma non è possibile aprirlo, viene generato un evento di errore di script, con un messaggio con il contenuto seguente:

Impossibile caricare le variabili dello script.

  • Verifica se sono stati creati nuovi dettagli di arresto anomalo dopo l'ultimo controllo eseguito. In questo caso, viene generato un evento per segnalare i nuovi dettagli di arresto anomalo. Per generare l'evento di errore di script, lo script esegue le operazioni seguenti:
    • Ottiene la directory di installazione di Configuration Manager indicata nel Registro di sistema nella chiave Identification di SMS, nel valore "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\Installation Directory". Se non è possibile ottenere il percorso, lo script genera un messaggio di evento di errore di script con un testo simile al seguente e viene chiuso:

Impossibile leggere il valore del Registro di sistema.

  • Genera il percorso completo della directory CrashDumps aggiungendo "\Logs\CrashDumps" alla directory di installazione di Configuration Manager recuperata.
  • Verifica se la directory CrashDumps esiste. In caso contrario, lo script viene chiuso senza eseguire ulteriori azioni.
  • Se la directory CrashDumps esiste, dalla raccolta VarSet viene recuperata l'ultima data di creazione della cartella dei dettagli di arresto anomalo.
  • Verifica se sono stati creati nuovi dettagli di arresto anomalo ed esegue azioni solo per i più recenti. Per determinare quali sono i dettagli più recenti, viene utilizzata la data di creazione della cartella salvata degli ultimi dettagli di arresto anomalo, se disponibile. Il confronto di data e ora è basato sulla data di creazione della cartella con un livello di precisione di un secondo.
  • Se sono stati creati nuovi dettagli di arresto anomalo o se è la prima volta che lo script viene eseguito, lo script registra e crea l'evento 1710, specificando il percorso e la cartella dei nuovi dettagli di arresto anomalo. Lo script salva la data di creazione della cartella dei dettagli di arresto anomalo nella raccolta VarSet.
  • Scrive i contenuti della raccolta VarSet nel file ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet locale e chiude il file. Se il file non esiste, viene creato. Se non erano state impostate variabili VarSet, non viene visualizzata alcuna voce relativa nel file. Se si verifica un errore durante la scrittura del file, viene generato un messaggio di evento di errore di script con un testo simile al seguente: Impossibile salvare le variabili dello script.

Evento di monitoraggio dei dettagli di arresto anomalo SMS Executive di ConfigMgr 2007

Lo script ConfigMgr 2007 Monitor SMS Executive Crash Dumps segnala, tramite l'evento 1710, che si è verificato un arresto anomalo, come descritto di seguito:

EventType = Errore

EventNumber= 1710

Category = Codice sito di SMS

Description = Arresto anomalo di SMS Executive nel sito “XXX”. Per informazioni, vedere i dettagli di arresto anomalo in <Drive> <ConfigMgrInstallationPath>\Logs\CrashDumps\NewFolder.

Evento di errore dello script di monitoraggio dettagli di arresto anomalo SMS Executive di ConfigMgr 2007

Lo script “SMS 2003 Monitor SMS Executive Crash Dumps” segnala gli errori di script di runtime tramite l'evento 1102.

EventType = Avviso

EventNumber= 1102

Description = Nello script “SMS 2003 Monitor SMS Executive Crash Dumps” in esecuzione con la regola di elaborazione SMS 2003 Crash Dumps: Monitoring SMS Executive si è verificato un errore di runtime. CrLf “Impossibile <Message>." ErrorString

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Viste per Configuration Manager 2007 Management Pack

In Configuration Manager 2007 Management Pack sono disponibili le viste comuni seguenti:

  • Avvisi
  • Stato computer
  • Eventi
  • Diagramma gerarchia siti
  • Stato gerarchia siti
  • Stato siti
  • Stato attività
  • e le cartelle di viste di categoria seguenti:
  • Generale
  • Prestazioni

Generale

  • Avvisi dal server del sito centrale ricevuti nelle ultime 72 ore
  • Nuovi avvisi nelle ultime 72 ore

Viste relative alle prestazioni

È possibile configurare le viste in modo da visualizzare i dati di determinati computer in una vista specifica. È possibile ridurre la complessità del grafico selezionando il contatore specifico per i computer di interesse.

Backlog\server dei punti di gestione

  • Backlog record dei dati di individuazione nelle ultime 48 ore
  • Backlog raccolta file nelle ultime 48 ore
  • Backlog inventario hardware (HINV) nelle ultime 48 ore
  • Backlog cartella posta in uscita ddr.box nelle ultime 48 ore
  • Backlog cartella posta in uscita distmgr.box nelle ultime 48 ore
  • Backlog cartella posta in uscita hinv.box nelle ultime 48 ore
  • Backlog cartella posta in uscita rdr.box nelle ultime 48 ore
  • Backlog cartella posta in uscita sinv.box nelle ultime 48 ore
  • Backlog cartella posta in uscita stat.box nelle ultime 48 ore
  • Backlog cartella posta in uscita statemsg.box nelle ultime 48 ore
  • Backlog cartella posta in uscita swm.box nelle ultime 48 ore
  • Backlog inoltro nelle ultime 48 ore
  • Backlog inventario software (SINV) nelle ultime 48 ore
  • Backlog stato nelle ultime 48 ore

Backlog\server del punto di servizio PXE

  • Richieste database in sospeso nelle ultime 24 ore

Backlog\server basati su SMS Executive

  • Backlog cartella posta in uscita stat.box nelle ultime 48 ore
  • Backlog cartella posta in uscita statemsg.box nelle ultime 48 ore

Backlog\server del sito

  • Backlog record dei dati di individuazione nelle ultime 48 ore
  • Backlog inventario hardware (HINV) nelle ultime 48 ore
  • Backlog cartella posta in arrivo auth/dataldr.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo auth/ddm.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo auth/sinv.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo auth/statesys.box/incoming nelle ultime 48 ore
  • Backlog cartella posta in arrivo ciamgr.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo ciamgr.box/RETRY nelle ultime 48 ore
  • Backlog cartella posta in arrivo compsumm.box/repl nelle ultime 48 ore
  • Backlog cartella posta in arrivo dataldr.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo ddm.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo despoolr.box/receive nelle ultime 48 ore
  • Backlog cartella posta in arrivo objmgr.box/INCOMING nelle ultime 48 ore
  • Backlog cartella posta in arrivo objmgr.box/INCOMING/Retry nelle ultime 48 ore
  • Backlog cartella posta in arrivo offermgr.box/INCOMING nelle ultime 48 ore
  • Backlog cartella posta in arrivo offersum.box/repl nelle ultime 48 ore
  • Backlog cartella posta in arrivo schedule.box/outboxes/LAN nelle ultime 48 ore
  • Backlog cartella posta in arrivo schedule.box/requests nelle ultime 48 ore
  • Backlog cartella posta in arrivo sinv.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo sitestat.box/repl nelle ultime 48 ore
  • Backlog cartella posta in arrivo statmgr.box/statmsgs nelle ultime 48 ore
  • Backlog cartella posta in arrivo swmproc.box/usage nelle ultime 48 ore
  • Backlog cartella posta in arrivo WOLCMGR.box nelle ultime 48 ore
  • Backlog cartella posta in arrivo WOLCMGR.box/data nelle ultime 48 ore
  • Backlog processi componente di pianificazione nelle ultime 48 ore
  • Backlog richieste invio componente di pianificazione nelle ultime 48 ore
  • Backlog inventario software (SINV) nelle ultime 48 ore
  • Backlog controllo software (SWM) nelle ultime 48 ore
  • Totale richieste di riattivazione LAN (WOL) in sospeso nelle ultime 48 ore

Condizioni\server del punto di migrazione dello stato

  • Totale spazio disponibile su disco nell'ultima ora

Condizioni\server del servizio di convalida dell'integrità di sistema

  • Cookie di patch non validi nelle ultime 24 ore
  • Cookie di patch mancanti nelle ultime 24 ore
  • Cookie di patch nuovi nelle ultime 24 ore
  • Cookie di patch Null nelle ultime 24 ore
  • Cookie di patch obsoleti nelle ultime 24 ore
  • Cookie di patch uguali nelle ultime 24 ore
  • Patch non installate nelle ultime 24 ore
  • Agente client Protezione accesso alla rete SMS disattivato nelle ultime 24 ore
  • Scadenza data assoluta rapporto di integrità nelle ultime 24 ore
  • TTL scaduto rapporto di integrità nelle ultime 24 ore

Generale\<tipo server>

Le viste seguenti sono disponibili per i server del punto di gestione, del punto di servizio PXE, del sito, del punto di aggiornamento del software, del punto di migrazione dello stato e di convalida dell'integrità di sistema.

  • Disco logico nelle ultime 48 ore
  • Memoria nelle ultime 48 ore
  • Processore nelle ultime 48 ore

Velocità di elaborazione

  • *Tutte le velocità di elaborazione dei messaggi in un server del punto di gestione ConfigMgr 2007 nelle ultime 24 ore
  • *Tutte le velocità di elaborazione dei report in un server del punto di gestione ConfigMgr 2007 nelle ultime 24 ore
  • *Tutte le velocità di elaborazione report in un server del sito ConfigMgr 2007 nelle ultime 24 ore

Velocità di elaborazione\server del punto di gestione

  • Record dei dati di individuazione/sec nelle ultime 24 ore
  • Tentativi di connessione al database/sec gestione dispositivi nelle ultime 24 ore
  • Record dei dati di individuazione/sec gestione dispositivi nelle ultime 24 ore
  • Richieste di conversione dei record di individuazione/sec gestione dispositivi nelle ultime 24 ore
  • Posizioni punto di distribuzione gestione dispositivo/sec nelle ultime 24 ore
  • Richieste di conversione dell'inventario hardware/sec gestione dispositivi nelle ultime 24 ore
  • Inventari hardware (HINV)/sec gestione dispositivi nelle ultime 24 ore
  • Richieste ISAPI/sec gestione dispositivi nelle ultime 24 ore
  • Richieste impostazione computer/sec gestione dispositivi nelle ultime 24 ore
  • Richieste versione pacchetto/sec gestione dispositivi nelle ultime 24 ore
  • Inventari software (SINV)/sec gestione dispositivi nelle ultime 24 ore
  • Richieste corpo criteri software/sec gestione dispositivi nelle ultime 24 ore
  • Richieste ID criteri software/sec gestione dispositivi nelle ultime 24 ore
  • Messaggi di stato/sec gestione dispositivi nelle ultime 24 ore
  • Totale richieste impostazione/sec gestione dispositivi nelle ultime 24 ore
  • Posizioni punto di distribuzione/sec nelle ultime 24 ore
  • Richieste pacchetti SDM non riuscite/sec nelle ultime 24 ore
  • Richieste pacchetti SDM/sec nelle ultime 24 ore
  • Richieste di autenticazione/sec nelle ultime 24 ore
  • Richieste di criteri/sec nelle ultime 24 ore
  • Inventari hardware (HINV)/sec nelle ultime 24 ore
  • Richieste ISAPI/sec nelle ultime 24 ore
  • Posizioni punto di gestione/sec nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita ddr.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita ddr.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita ddr.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita distmgr.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita distmgr.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita distmgr.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita hinv.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita hinv.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita hinv.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita rdr.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita rdr.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita rdr.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita sinv.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita sinv.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita sinv.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita stat.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita stat.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita stat.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita statemsg.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita statemsg.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita statemsg.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita swm.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita swm.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita swm.box nelle ultime 24 ore
  • Richieste assegnazione criteri/sec nelle ultime 24 ore
  • Report inoltro/sec nelle ultime 24 ore
  • Latenza media richieste disponibilità server punto di gestione dei dispositivi nelle ultime 24 ore
  • Richieste disponibilità server non riuscite punto di gestione dei dispositivi nelle ultime 24 ore
  • Richieste disponibilità server riuscite punto di gestione dei dispositivi nelle ultime 24 ore
  • Totale richieste disponibilità server punto di gestione dei dispositivi nelle ultime 24 ore
  • Richieste disponibilità server riuscite punto di gestione nelle ultime 24 ore
  • Totale richieste disponibilità server punto di gestione nelle ultime 24 ore
  • Inventari software (SINV)/sec nelle ultime 24 ore
  • Stored procedure eseguite/sec nelle ultime 24 ore
  • Messaggi sullo stato attuale elaborati/sec nelle ultime 24 ore
  • Messaggi sullo stato attuale rifiutati nelle ultime 24 ore
  • Stato/sec nelle ultime 24 ore
  • Totale record dei dati di individuazione nelle ultime 24 ore
  • Totale record dei dati di individuazione gestione dispositivi nelle ultime 24 ore
  • Totale inventari hardware (HINV) gestione dispositivi nelle ultime 24 ore
  • Totale richieste ISAPI inviate gestione dispositivi nelle ultime 24 ore
  • Totale richieste ISAPI ricevute gestione dispositivi nelle ultime 24 ore
  • Totale inventari software (SINV) gestione dispositivi nelle ultime 24 ore
  • Totale stato gestione dispositivi nelle ultime 24 ore
  • Totale richieste pacchetti SDM non riuscite nelle ultime 24 ore
  • Totale richieste pacchetti SDM nelle ultime 24 ore
  • Totale inventari hardware (HINV) nelle ultime 24 ore
  • Totale report inoltro nelle ultime 24 ore
  • Totale inventari software (SINV) nelle ultime 24 ore
  • Totale messaggi sullo stato attuale elaborati nelle ultime 24 ore
  • Totale stato nelle ultime 24 ore

Velocità di elaborazione\server del punto di servizio PXE

  • Richieste database elaborate nelle ultime 24 ore
  • Richieste database elaborate/secondo nelle ultime 24 ore
  • Richieste di individuazione DHCP elaborate nelle ultime 24 ore
  • Richieste di individuazione DHCP elaborate/secondo nelle ultime 24 ore
  • Richieste PXE elaborate nelle ultime 24 ore
  • Richieste PXE elaborate/secondo nelle ultime 24 ore
  • Latenza media richieste disponibilità server punto di servizio PXE nelle ultime 24 ore
  • Richieste disponibilità server non riuscite punto di servizio PXE nelle ultime 24 ore
  • Richieste disponibilità server riuscite punto di servizio PXE nelle ultime 24 ore
  • Totale richieste disponibilità server punto di servizio PXE nelle ultime 24 ore
  • Totale richieste non riuscite nelle ultime 24 ore
  • Totale richieste nelle ultime 24 ore
  • Totale richieste/sec nelle ultime 24 ore

Velocità di elaborazione\server basati su SMS Executive

  • File copiati/minuto cartella posta in uscita stat.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita stat.box nelle ultime 24 ore
  • Totale file copiati cartella posta in uscita stat.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita statemsg.box nelle ultime 24 ore
  • Totale errori copia file cartella posta in uscita statemsg.box nelle ultime 24 ore
  • File copiati/minuto cartella posta in uscita statemsg.box nelle ultime 24 ore

Velocità di elaborazione\server del sito

  • Media aggiornamenti scritti al minuto nelle ultime 24 ore
  • Record dei dati di individuazione/minuto nelle ultime 24 ore
  • Inventari hardware (HINV)/minuto nelle ultime 24 ore
  • Numero di pacchetti di riattivazione LAN (WOL) al secondo nelle ultime 24 ore
  • Inventari software (SINV)/minuto nelle ultime 24 ore
  • Thread di elaborazione file messaggi sullo stato attuale nelle ultime 24 ore
  • File di messaggi sullo stato attuale elaborati/minuto nelle ultime 24 ore
  • Record di messaggi sullo stato attuale elaborati/minuto nelle ultime 24 ore
  • Stato/minuto nelle ultime 24 ore
  • Controlli software (SWM)/minuto nelle ultime 24 ore
  • Totale file di messaggi sullo stato attuale non validi nelle ultime 24 ore
  • Totale record dei dati di individuazione nelle ultime 24 ore
  • Totale inventari hardware (HINV) nelle ultime 24 ore
  • Totale record di messaggi sullo stato attuale non validi elaborati nelle ultime 24 ore
  • Numero totale di pacchetti di riattivazione LAN (WOL) non riusciti nelle ultime 24 ore
  • Numero totale di pacchetti di riattivazione LAN (WOL) inviati nelle ultime 24 ore
  • Totale inventari software (SINV) nelle ultime 24 ore
  • Totale file di messaggi sullo stato attuale elaborati nelle ultime 24 ore
  • Totale record di messaggi sullo stato attuale non elaborati nelle ultime 24 ore
  • Totale record di messaggi sullo stato attuale elaborati nelle ultime 24 ore
  • Totale stato nelle ultime 24 ore
  • Totale controlli software (SWM) nelle ultime 24 ore
  • Totale aggiornamenti scritti nelle ultime 24 ore

Velocità di elaborazione\server del punto di migrazione dello stato

  • Client con salvataggi completati dello stato attuale nell'ultima ora
  • Client con ripristini in corso dello stato attuale nell'ultima ora
  • Client con salvataggi in corso dello stato attuale nell'ultima ora
  • Latenza media richieste disponibilità server punto di migrazione dello stato nelle ultime 24 ore
  • Richieste disponibilità server non riuscite punto di migrazione dello stato nelle ultime 24 ore
  • Richieste disponibilità server riuscite punto di migrazione dello stato nelle ultime 24 ore
  • Totale richieste disponibilità server punto di migrazione dello stato nelle ultime 24 ore
  • Numero totale di client rifiutati nell'ultima ora

Velocità di elaborazione\server del servizio di convalida dell'integrità di sistema

  • Richieste rapporto di integrità al secondo nelle ultime 24 ore
  • Totale richieste rapporto di integrità nelle ultime 24 ore
  • Fragilità client in risposte al rapporto di integrità nelle ultime 24 ore
  • Stato conforme in risposte al rapporto di integrità nelle ultime 24 ore
  • Errori invio risposte rapporto di integrità nelle ultime 24 ore
  • Stato non conforme in risposte al rapporto di integrità nelle ultime 24 ore
  • Fragilità server in risposte al rapporto di integrità nelle ultime 24 ore
  • Stato sconosciuto in risposte al rapporto di integrità nelle ultime 24 ore

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Diagrammi per Configuration Manager 2007 Management Pack

In Configuration Manager 2007 Management Pack è disponibile un diagramma per la gerarchia dei siti di Configuration Manager 2007. I server del sito e i sistemi del sito vengono visualizzati con le relazioni corrispondenti e informazioni sensibili al contesto. Il diagramma della topologia include dati logici quali gerarchie e siti nonché dati fisici quali server del sito e sistemi del sito. Le gerarchie di Configuration Manager 2007 possono essere di grandi dimensioni e pertanto i diagrammi devono soddisfare i requisiti seguenti:

  • L'agente di Operations Manager 2007 deve essere installato localmente in tutti i server del sito centrale e nei relativi provider SMS.
  • Installare l'agente di Operations Manager 2007 localmente in tutti i server del sito primario con un approccio dall'alto verso il basso, in base al numero di livelli desiderato nella gerarchia dei siti di Configuration Manager.
  • Per ogni agente di Operations Manager 2007 installato deve essere attivato l'inoltro dei dati.
  • Per ogni server che deve essere individuato da Operations Manager, immettere il nome di dominio completo tramite la console di amministrazione di Configuration Manager 2007.
  • I server di Configuration Manager devono essere stati individuati e devono essere presenti nella raccolta All Systems nella console di amministrazione di Configuration Manager.
  • Le istanze di server ConfigMgr devono essere individuate dall'individuazione dei servizi.

L'individuazione viene eseguita dai due script seguenti.

  • ConfigMgr 2007 - individuazione servizi - Server
  • ConfigMgr 2007 - individuazione gerarchia dei siti

Individuazione servizi esegue l'individuazione delle istanze della classe Server ConfigMgr. Individuazione gerarchia dei siti esegue l'individuazione degli elementi seguenti:

  • Siti centrali, primari e secondari in base ai singoli siti dal provider di un sito primario
  • Relazione da sito a sito
  • Server all'interno di un sito
  • Relazioni tra server del sito e sistemi del sito

I dati di individuazione possono essere visualizzati parzialmente nel diagramma e in modo più completo nelle proprietà degli oggetti. È inoltre possibile salvare i diagrammi nei formati di file con estensione jpeg, bmp o png.

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Report per Configuration Manager 2007 Management Pack


Report per Configuration Manager 2007 Management Pack

I report descritti in questa sezione sono disponibili in Configuration Manager 2007 Management Pack. La funzionalità di report è un componente facoltativo di Operations Manager che deve essere installato a parte. Per ulteriori informazioni sulla distribuzione del server di report, vedere la pagina Web del prodotto Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Funzionalità di report di Configuration Manager 2007

Configuration Manager 2007 Management Pack include tre tipi di report:

  • Disponibilità
  • Configurazione
  • Prestazioni

I report vengono messi in relazione a gruppi o oggetti attraverso il selettore di oggetti. Tutti i report sono collegati per utilizzare le funzionalità di report di Operations Manager 2007. Sono disponibili sette diversi formati esportabili per i report.

Report di disponibilità

I report di disponibilità inclusi in Configuration Manager 2007 Management Pack vengono messi in relazione alla classe Server ConfigMgr e ai relativi monitoraggi. Possono essere eseguiti selezionando il gruppo Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup o l'oggetto Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class nel selettore oggetti del report.

Disponibilità del server

Questo report si basa sullo stato di integrità aggregato di tutte le entità di un determinato server e include lo stato di disponibilità per System.Health.EntityState.

Disponibilità del punto di distribuzione

Questo report di basa sullo stato di disponibilità di un punto di distribuzione e utilizza le informazioni del monitoraggio di stato del punto di distribuzione.

Disponibilità del punto di gestione

Questo report di basa sullo stato di disponibilità di un punto di gestione e utilizza le informazioni del monitoraggio di stato del punto di gestione.

Disponibilità del punto di servizio PXE

Questo report di basa sullo stato di disponibilità di un punto di servizio PXE e utilizza le informazioni del monitoraggio di stato del punto di servizio PXE.

Disponibilità del server del sito

Questo report di basa sullo stato di disponibilità di un server del sito e utilizza le informazioni del monitoraggio di stato del server del sito.

Disponibilità del punto di aggiornamento del software

Questo report di basa sullo stato di disponibilità di un punto di aggiornamento del software e utilizza le informazioni del monitoraggio di stato del punto di aggiornamento del software.

Disponibilità del servizio di convalida dell'integrità di sistema

Questo report di basa sullo stato di disponibilità di un punto di convalida dell'integrità di sistema e utilizza le informazioni del monitoraggio di stato del servizio di convalida dell'integrità di sistema.

Report di configurazione

In Configuration Manager 2007 Management Pack è disponibile un solo report di configurazione, il report Configurazione personalizzata server ConfigMgr 2007. In questo report vengono visualizzate le proprietà della classe Server ConfigMgr seguenti:

  • Versione (versione del prodotto di Configuration Manager 2007)
  • Tipo di sistema del sito (tipo di sistema del sito, tipo di server, tipo di server di database)
  • Componenti (server del sito, punto di localizzazione del server, punto di distribuzione, punto di gestione, punto di reporting, server di database, provider, server Sender, punto di accesso client)
  • Codice del sito (codice del sito SMS)
  • Tipo di server (centrale, primario, server del sito secondario)
  • Nome (nome NetBIOS)
  • Tipo di server di database (server di database del sito)

Questo report può essere eseguito selezionando il gruppo Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup o l'oggetto Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class nel selettore oggetti del report.

Report di prestazioni

I report di prestazioni vengono raggruppati in base ai ruoli del server o agli oggetti di Configuration Manager, ad esempio in base a un punto di gestione o a un record dei dati di individuazione. Tali gruppi sono ulteriormente suddivisi in tipi puri (totali) e di frequenza (valore al secondo o al minuto), per adattare i valori in modo appropriato all'interno del report.

I report e i relativi contatori delle prestazioni sono organizzati in questo modo per facilitare l'analisi delle tendenze e la risoluzione dei problemi. Il report degli oggetti viene in genere utilizzato quando si analizzano problemi relativi all'infrastruttura di Configuration Manager, mentre un report dei ruoli del server risulta utile per risolvere problemi relativi, ad esempio, a uno o più punti di gestione.

Report del Gruppo Prestazioni server ConfigMgr 2007

Per eseguire i report seguenti, selezionare Microsoft.SystemCenter.ConfigurationManager.2007.ServerPerformanceGroup nel gruppo di destinazione del selettore oggetti.

Report Prestazioni frequenza record dei dati di individuazione ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione dei record dei dati di individuazione per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record dei dati di individuazione server del sito | Record dati elaborazione elaborati al minuto
Misurazione prestazioni ConfigMgr 2007: gestione record dei dati di individuazione punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record dei dati di individuazione punto di gestione dei dispositivi | Report individuazione generati/secondo

Report Prestazioni pure record dei dati di individuazione ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog dei record dei dati di individuazione elaborati per tutti i ruoli del server di Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: backlog record dei dati di individuazione server del sito | Il totale indica la frequenza dei record dei dati di individuazione accodati
Misurazione prestazioni ConfigMgr 2007: totale record dei dati di individuazione server del sito elaborati | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record dei dati di individuazione punto di gestione dei dispositivi | Report individuazione generati/secondo

Prestazioni pure punto di gestione dei dispositivi ConfigMgr 2007

In questo report vengono visualizzati i totali elaborati per il ruolo del server Punto di gestione dei dispositivi Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: totale record dei dati di individuazione elaborati punto di gestione dei dispositivi | Totale report individuazione generati
Misurazione prestazioni ConfigMgr 2007: totale inventari hardware (HINV) elaborati punto di gestione dei dispositivi | Totale report inventario hardware generati
Misurazione prestazioni ConfigMgr 2007: totale inventari software (SINV) elaborati punto di gestione dei dispositivi | Totale report inventario software generati
Misurazione prestazioni ConfigMgr 2007: totale messaggi di stato elaborati punto di gestione dei dispositivi | Totale messaggi di stato generati
Misurazione prestazioni ConfigMgr 2007: totale richieste ISAPI inviate punto di gestione dei dispositivi | Totale messaggi inviati
Misurazione prestazioni ConfigMgr 2007: totale richieste ISAPI ricevute punto di gestione dei dispositivi | Totale messaggi ricevuti

Prestazioni frequenza punto di gestione dei dispositivi ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione per il ruolo del server Punto di gestione dei dispositivi Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: frequenza richieste impostazione punto di gestione dei dispositivi | Richieste impostazione del punto di gestione dei dispositivi/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste impostazione computer punto di gestione dei dispositivi | Richieste impostazione computer/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste ID criteri software punto di gestione dei dispositivi | Richieste ID criteri software/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste corpo criteri software punto di gestione dei dispositivi | Richieste corpo criteri software/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste versione pacchetto punto di gestione dei dispositivi | Richieste versione pacchetto/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste conversione record di individuazione punto di gestione dei dispositivi | Richieste conversione record di individuazione/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza richieste conversione inventario hardware punto di gestione dei dispositivi | Richieste conversione inventario hardware/secondo
Misurazione prestazioni ConfigMgr 2007: frequenza tentativi di connessione al database punto di gestione dei dispositivi | Tentativi di connessione al database/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record dei dati di individuazione punto di gestione dei dispositivi | Report individuazione generati/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario hardware (HINV) punto di gestione dei dispositivi | Report inventario hardware generati/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione richieste posizione punto di distribuzione punto di gestione dei dispositivi | Richieste posizione generate/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione messaggi ISAPI punto di gestione dei dispositivi | Messaggi inviati/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario software (SINV) punto di gestione dei dispositivi | Report inventario software generati/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione stato punto di gestione dei dispositivi | Messaggi di stato generati/secondo

Prestazioni frequenza inventario hardware (HINV) ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione dell'inventario hardware (HINV) per tutti i ruoli del server SMS applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario hardware (HINV) server del sito | MIF elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: gestione inventario hardware punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione nuovo tentativo inventario hardware punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario hardware (HINV) punto di gestione dei dispositivi | Report inventario hardware generati/secondo

Prestazioni pure inventario hardware (HINV) ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog dell'inventario hardware elaborati per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: backlog inventario hardware (HINV) server del sito | Totale MIF in coda
Misurazione prestazioni ConfigMgr 2007: totale inventari hardware (HINV) server del sito elaborati | Totale MIF elaborati
Misurazione prestazioni ConfigMgr 2007: backlog inventario hardware (HINV) punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inventario hardware punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: totale inventari hardware (HINV) elaborati punto di gestione dei dispositivi | Totale report inventario hardware generati

Prestazioni frequenza punto di gestione ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione per il ruolo del server Punto di gestione Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: gestione posizione punto di gestione (richieste punto di gestione/sec) | Richieste MP/sec
Misurazione prestazioni ConfigMgr 2007: gestione posizione punto di gestione (richieste punto di distribuzione/sec) | Richieste DP/sec
Misurazione prestazioni ConfigMgr 2007: richieste di criteri punto di gestione (richieste/sec) | Richieste/secondo
Misurazione prestazioni ConfigMgr 2007: richieste di autenticazione punto di gestione (richieste/sec) | Richieste/secondo
Misurazione prestazioni ConfigMgr 2007: gestione dei criteri punto di gestione (richieste di assegnazione criteri/sec) | Richieste PA/sec
Misurazione prestazioni ConfigMgr 2007: livello di accesso ai dati punto di gestione (stored procedure eseguite/sec) | SP eseguiti/sec
Misurazione prestazioni ConfigMgr 2007: gestione inventario hardware punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione nuovo tentativo inventario hardware punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione inventario software punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione file raccolta inventario software punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione inoltro punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione stato punto di gestione (totale eventi/sec) | Totale eventi/secondo

Prestazioni pure punto di gestione ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog elaborati per il ruolo del server Punto di gestione Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: backlog record dei dati di individuazione punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione record dei dati di individuazione punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: backlog inventario hardware (HINV) punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inventario hardware punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: backlog raccolta file punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: backlog inventario software (SINV) punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inventario software punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: backlog gestione inoltro punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inoltro punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: backlog stato punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione stato punto di gestione (totale eventi) | Totale eventi

Prestazioni risorse di sistema server ConfigMgr 2007

In questo report viene visualizzato l'utilizzo delle risorse di sistema da parte dei ruoli del server di Configuration Manager 2007.

Misurazione prestazioni ConfigMgr 2007: Memoria - % byte vincolati in uso | Byte impegnati in uso
Misurazione prestazioni ConfigMgr 2007: % utilizzo file di paging | Percentuale di utilizzo
Misurazione prestazioni ConfigMgr 2007: processore - % tempo processore (_totale) | Percentuale di tempo processore
Misurazione prestazioni ConfigMgr 2007: % tempo processore processo (smsexec) | Percentuale di tempo processore
Misurazione prestazioni ConfigMgr 2007: % tempo processore processo (ccmexec) | Percentuale di tempo processore
Misurazione prestazioni ConfigMgr 2007: tempo di funzionamento sistema | Tempo di attività del sistema

Prestazioni pure server del sito ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione per il ruolo del server Server del sito Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: backlog processi componente di pianificazione server del sito | Numero di processi
Misurazione prestazioni ConfigMgr 2007: backlog richieste invio componente di pianificazione server del sito | Numero di richeste di invio
Misurazione prestazioni ConfigMgr 2007: stati thread SMS Executive (conteggio thread in esecuzione: _totale) | Conteggio dei thread in esecuzione
Misurazione prestazioni ConfigMgr 2007: backlog record dei dati di individuazione server del sito | Totale record dei dati di individuazione in coda
Misurazione prestazioni ConfigMgr 2007: totale record dei dati di individuazione server del sito elaborati | Totale record dei dati di individuazione elaborati
Misurazione prestazioni ConfigMgr 2007: backlog inventario hardware (HINV) server del sito | Totale MIF in coda
Misurazione prestazioni ConfigMgr 2007: totale inventari hardware (HINV) server del sito elaborati | Totale MIF elaborati
Misurazione prestazioni ConfigMgr 2007: backlog inventario software (SINV) server del sito | Totale SINV in coda
Misurazione prestazioni ConfigMgr 2007: totale inventari software (SINV) server del sito elaborati | Totale SINV elaborati
Misurazione prestazioni ConfigMgr 2007: backlog controllo software (SWM) server del sito | Totale file utilizzo SWM in coda
Misurazione prestazioni ConfigMgr 2007: totale controlli software (SWM) server del sito elaborati | Totale file utilizzo SWM elaborati
Misurazione prestazioni ConfigMgr 2007: totale messaggi di stato server del sito elaborati | Ricevuti
Misurazione prestazioni ConfigMgr 2007: totale record di messaggi elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi elaborati
Misurazione prestazioni ConfigMgr 2007: totale record di messaggi non validi elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi non validi elaborati
Misurazione prestazioni ConfigMgr 2007: totale record di messaggi non elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi non elaborati
Misurazione prestazioni ConfigMgr 2007: totale file di messaggi elaborati sistema messaggi sullo stato attuale SMS | Totale file di messaggi elaborati
Misurazione prestazioni ConfigMgr 2007: totale file di messaggi non validi elaborati sistema messaggi sullo stato attuale SMS | Totale file di messaggi non validi elaborati
Misurazione prestazioni ConfigMgr 2007: thread di elaborazione file di messaggi sistema messaggi sullo stato attuale SMS | Thread di elaborazione dei file di messaggi
Misurazione prestazioni ConfigMgr 2007: numero totale pacchetti inviati componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS | Numero totale di pacchetti inviati
Misurazione prestazioni ConfigMgr 2007: numero totale pacchetti non riusciti componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS | Numero totale di pacchetti non riusciti
Misurazione prestazioni ConfigMgr 2007: numero totale richieste in sospeso componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS | Numero totale di richieste in sospeso

Prestazioni frequenza server del sito ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione per il ruolo del server Server del sito Microsoft ConfigMgr 2007.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario hardware (HINV) server del sito | MIF elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario software (SINV) server del sito | SINV elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione controllo software (SWM) server del sito | Record utilizzo SWM elaborati / minuto
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione stato server del sito | Record elaborati/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record di messaggi sistema messaggi sullo stato attuale SMS | Velocità di elaborazione
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione file di messaggi sistema messaggi sullo stato attuale SMS | File di messaggi elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: numero pacchetti al secondo componente di gestione delle comunicazioni di riattivazione LAN (WOL) SMS | Numero di pacchetti al secondo

Prestazioni frequenza inventario software (SINV) ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione dell'inventario software (SINV) per tutti i ruoli server di Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario software (SINV) server del sito | SINV elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: gestione inventario software punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: gestione file raccolta inventario software punto di gestione (totale report/sec) | Totale report/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione inventario software (SINV) punto di gestione dei dispositivi | Report inventario software generati/secondo

Prestazioni pure inventario software (SINV) ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog dell'inventario software elaborati per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: backlog inventario software (SINV) server del sito | Totale SINV in coda
Misurazione prestazioni ConfigMgr 2007: totale inventari software (SINV) server del sito elaborati | Totale SINV elaborati
Misurazione prestazioni ConfigMgr 2007: backlog raccolta file punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: backlog inventario software (SINV) punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inventario software punto di gestione (totale report) | Totale report
Misurazione prestazioni ConfigMgr 2007: totale inventari software (SINV) elaborati punto di gestione dei dispositivi | Totale report inventario software generati

Prestazioni pure controllo software (SWM) ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog del controllo software (SWM) elaborati per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: backlog controllo software (SWM) server del sito | Totale file utilizzo SWM in coda
Misurazione prestazioni ConfigMgr 2007: totale controlli software (SWM) server del sito elaborati | Totale record utilizzo SWM elaborati
Misurazione prestazioni ConfigMgr 2007: backlog gestione inoltro punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione inoltro punto di gestione (totale report) | Totale report

Prestazioni frequenza controllo software (SWM) ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione del controllo software (SWM) per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione controllo software (SWM) server del sito | Record utilizzo SWM elaborati / minuto
Misurazione prestazioni ConfigMgr 2007: gestione inoltro punto di gestione (totale report/sec) | Totale report/secondo

Prestazioni pure messaggi sullo stato attuale ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog dei messaggi di stato di Configuration Manager 2007 elaborati per tutti i ruoli del server SMS applicabili.

Misurazione prestazioni ConfigMgr 2007: totale record di messaggi elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi elaborati
Misurazione prestazioni ConfigMgr 2007: totale record di messaggi non validi elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi non validi elaborati
Misurazione prestazioni ConfigMgr 2007: totale record di messaggi non elaborati sistema messaggi sullo stato attuale SMS | Totale record di messaggi non elaborati
Misurazione prestazioni ConfigMgr 2007: totale file di messaggi elaborati sistema messaggi sullo stato attuale SMS | Totale file di messaggi elaborati
Misurazione prestazioni ConfigMgr 2007: totale file di messaggi non validi elaborati sistema messaggi sullo stato attuale SMS | Totale file di messaggi non validi elaborati
Misurazione prestazioni ConfigMgr 2007: thread di elaborazione file di messaggi sistema messaggi sullo stato attuale SMS | Thread di elaborazione dei file di messaggi
Misurazione prestazioni ConfigMgr 2007: messaggi sullo stato attuale elaborati punto di gestione | Totale messaggi
Misurazione prestazioni ConfigMgr 2007: messaggi sullo stato attuale rifiutati punto di gestione | Messaggi rifiutati

Prestazioni frequenza messaggi sullo stato attuale ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione dei messaggi sullo stato attuale SMS per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione record di messaggi sistema messaggi sullo stato attuale SMS | Record di messaggi elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione file di messaggi sistema messaggi sullo stato attuale SMS | File di messaggi elaborati/minuto
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione messaggi sullo stato attuale punto di gestione | Messaggi/secondo

Prestazioni pure messaggi di stato ConfigMgr 2007

In questo report vengono visualizzati i totali e i backlog dei messaggi sullo stato attuale SMS elaborati per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: totale messaggi di stato server del sito elaborati | Ricevuti
Misurazione prestazioni ConfigMgr 2007: backlog stato punto di gestione | Messaggi in coda
Misurazione prestazioni ConfigMgr 2007: gestione stato punto di gestione (totale eventi) | Totale eventi
Misurazione prestazioni ConfigMgr 2007: totale messaggi di stato elaborati punto di gestione dei dispositivi | Totale messaggi di stato generati

Prestazioni frequenza messaggi di stato ConfigMgr 2007

In questo report vengono visualizzate le frequenze di elaborazione dei messaggi sullo stato attuale SMS per tutti i ruoli del server Configuration Manager 2007 applicabili.

Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione stato server del sito | Record elaborati/secondo
Misurazione prestazioni ConfigMgr 2007: gestione stato punto di gestione (totale eventi/sec) | Totale eventi/secondo
Misurazione prestazioni ConfigMgr 2007: velocità di elaborazione stato punto di gestione dei dispositivi | Messaggi di stato generati/secondo

Prestazioni supporto ruoli del server ConfigMgr 2007

In questo report vengono visualizzate le prestazioni dei servizi che supportano i ruoli del server Configuration Manager 2007.

Misurazione prestazioni ConfigMgr 2007: servizio Web (richieste/sec estensione ISAPI)

Richieste estensioni ISAPI/secondo

Vedere anche

Concetti

Risorse aggiuntive per Configuration Manager 2007 Management Pack
Siti e componenti di Configuration Manager 2007 Management Pack
Gruppi di computer per Configuration Manager 2007 Management Pack
Classi di installazione per Configuration Manager 2007 Management Pack
Script per Configuration Manager 2007 Management Pack
Viste per Configuration Manager 2007 Management Pack
Diagrammi per Configuration Manager 2007 Management Pack